cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 Stuck Loading Into the Desktop Application

ShelbyStangGT
Explorer

I've been using my Oculus for almost a year and a half now and I've had to troubleshoot it about every time I've had to connect it to my PC. Eventually, it works and I can hop on and play whatever PC game I want through SteamVR. Today, however, my headset is stuck in the loading void animation before it connects to the Oculus app on my desktop. This was normal. Usually, I could unplug and replug the USB-C cable into my PC and it would work again. This time, it would keep loading. I tried:

- Unplugging and replugging the cable on both ends
- Restarting my PC
- Restarting my Headset
- Restarting both
- Using Air Link instead
- Using a faster internet
- Using and not using Ethernet
- Deleting and reinstalling the Oculus Application
- Deleting and reinstalling SteamVR and VR games, just in case
- Updating Drivers
- Checking for an Update on the Headset and Application

Almost everything short of getting a new headset I have attempted. I got log diagnostics if those can be looked at to locate a problem. Oddly enough, I also noticed my VR games struggling to load even on their desktop counterparts. So, I'm unsure if I deleted a necessary file for VR applications to work the previous day or not, but these issues are stressing me out. I hope I can hear back soon! Thank you!

7 REPLIES 7

ItsNoodIes
Protege

This sucks, I hate when you are ready to get down on some good VR gaming everything goes wrong with your equipment and the time you were ready to game is spent troubleshooting issues.

From what you said, it sounds like everything I would have also tried. When I get to the point you are at I ask myself, why did I just spend two hours futzing around trying to fix this and still it's not working when I could do what I know will most likely fix it in under 30 minutes. So lately this what I do and it has solved everything:

 

First uninstall the app from your PC, do make sure to back up any of your PC VR games and their saves. Normally I just rename the oculus folder to OculusBAK. Then uninstall the Meta application from your phone. Restart your PC, make sure to actually reboot, not just turn it on, do an actual restart to make sure it is fresh. Then reboot your phone. Now on your quest hold the power button while holding the volume down. When it boots up, in the menu, choose factory reset. Then once it boots up, hold the power button in till reboots. Now follow the setup in the headset. Install the Meta application on your phone. Once you setup the phone and the headset to the phone, reboot them both again. Then install your PCVR using the cable your headset came with. Once this is complete setup all your other apps. Now the last thing I do, while connected to PCVR is copy everything under that OculusBAK folder to the new oculus folder again while you are connected. It will tell you it cannot overwrite some files, that is okay, click skip when this happens.  This has always fixed any issues I have ever had. Yes it sounds like a lot, but think of how much time you can spend troubleshooting. I've lost countless hours. I do the same thing when I have crazy PC issues too. Seems to be quicker and easier to just nuke it and start over then troubleshooting for hours upon hours.

 

Hope this helps,

James 

It still won't load into the Quest Link after trying your method. I think something might be wrong with my headset after these years.image_2024-01-23_210441153.png

I get these error messages and sometimes the app tells me there is a general problem with my headset. I don't think its the software anymore.

Hey there, @ShelbyStangGT. Thanks for bringing this to our attention. We truly appreciated the steps you have been able to complete to get running smoothly on PCVR, so we'd love to continue taking a further look. While we're not able to assist regarding Steam VR concerns, we do want to make sure you're able to launch our software without any issues. Even though these steps may have been completed, we'd like to confirm the PCVR app was uninstalled, removing the following: 

 

  1. Disconnect the Link cable from the computer
  2. Disconnect your computer from the internet
  3. Backup any necessary content
  4. Reboot into Safe Mode
  5. Uninstall the Oculus PC app using the Control Panel
  6. Delete all Oculus folders from the following folder:
    • C:\Program Files
  7. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
    • Note: The AppData folder is usually hidden. Use these steps to access AppData.
      1. Press Windows key + R to launch the Run dialog window.
      2. Type %AppData% in the Run box and click OK or press Enter
      3. File Explorer will launch to the AppData\Roaming subfolder.
      4. Click AppData in the File Explorer address bar to show all three subfolders in the AppData location.
  8. Restart your computer in normal mode
  9. Reconnect your computer to the internet
  10. Install the Oculus PC app again using the setup tool from our website here
  11. Reconnect the Rift/Link cable and re-test the headset
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

After reviewing these steps, if done prior, and still experiencing this issue, do let us know! We'd next like to make sure your USB power settings and USB selective suspending is not active on your PC. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Still nothing, I just ended up getting a new headset. I wish this troubleshooting helped, but thanks for the replies and the help.

Update: My brand new Quest 3 won't even connect to the Quest Link via cord or Air Link. I don't know what's wrong with my software. I've done everything we could think of....

Hey @ShelbyStangGT, we can see your PM and will continue our conversation there!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?