Showing results for 
Search instead for 
Did you mean: 

Quest 2 Stuck on Looking For Headset

Honored Guest
I have  an iphone and it is stuck looking for headset

Community Manager
Community Manager
Hi there! Please make sure that the device you're using to connect to the Quest 2 is fully up to date and that you've got Bluetooth enabled and are connecting to the same WiFi network that your phone is connected to. Should the issue persist, please click here to submit a ticket and we'll be happy to help!
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest
Same problem. Further details - Bluetooth is enabled on my phone, but the headset does not come up in the list. Also, unclear where to connect to same wifi; also unclear where to input the code I see in the headset. I've submitted a ticket, but according to many users, those aren't responded to very quickly. 

Im having the same issue

I see your comment is only a few hours old and I know it's torture trying to get a new toy set up. I replied to another comment but you may not see it. You need to have both location and Bluetooth enabled on your phone or it won't pair properly. I needed to enable location and restart the Oculus app. Hope this helps.

also having this problem. gave it permission to use location while app is open, still stuck on looking for headset.


I also had the same problem.  I had to connect my phone to the same Wi-Fi network that the Oculus Quest 2 was using, then it worked!

Hey i had this issue on my intial setup and fixed it...

Leave headset on pairing mode on head so it stays awake...

Restart phone...

Before loading oculus app, turn on bluetooth and location services (you dont need to allow the app) 


Then when you load the oculus app it should find your headset without the code and offer to pair it.

Just to confirm: This worked for me.


The app was stuck in the "looking for headset" even though bluetooth was enabled on my Android smartphone.  All I had to do was

  1. close the app,
  2. reopen the app,
  3. allow it to use my location,

and then the pairing worked.  Notably, my headset was on the whole time and didn't need to be restarted...  But that is usually a good troubleshooting tip in general (ie, something not working?  Turn it off and on)


location access prompt on the phone

tapping blue next button just blinks and doesn't go to next screen

looking for headset and never does

bluetooth and location high accuracy and same wifi network as headset

what now?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?