cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 black screen, controllers wont connect.

Misinputs
Level 3

Hello.
After attempting to use my Quest 2 after only a day of inactivity, I only saw a tracking error screen no matter what I tried. After failing to fix this issue, I decided to factory reset my Quest 2. This made the problem even worse, as it now only displays a black, back-lit screen after the Meta logo appears. The sound still works, but the controllers vibrate every second or so, seemingly trying to connect to the headset (and failing every time). The app allows me to cast what the headset sees on my phone, but the picture is only black there too. I know it is not a display issue, as I can see the volume slider, red dot when casting, and the power off menu when I shut down the headset fine, albeit with tracking issues.

Things I have tried:
Multiple factory resets,
Covering the proximity sensor,

Charging headset to full battery,
Playing in different lighting conditions,
Sideload updating with a full firmware zip file,
Attempting to enable developer mode (does not allow me to through the app, despite having a developer account),
Attempting to start an application like Oculus Move through the app,
Replacing controller batteries,
Cleaning cameras with microfiber cloth,
Waiting.
All of these have resulted in the same black screen with vibrating controllers that doesn't allow me to do anything besides change the volume. The Quest 2 is in nearly perfect condition, but I purchased it from WalMart about two years ago. I'm not sure if there is any service I can receive because of that.

8 REPLIES 8

MetaQuestSupport
Community Manager
Community Manager

Hey @Misinputs! We see you're experiencing a black screen with your Quest 2 and appreciate you laying out all the troubleshooting steps you've attempted to try and get this resolved. We would like for you to enter a support ticket with us here and enter in all the details you've provided here so that we can have our specialist look into this further! 

BR_VR1
Level 2

I am in the exact same situation as you, I have been trying to get my sons oculus fixed again all night and Im assuming followed the same google search path you did. I still cant get it going and not being able to get into developer mode now is frustrating. After restarting it a million times, a few of those times I was able to see the initial screen with the controllers for a second but then right back to black screen. I have been trying to update firmware through adb however if you do the update through the admin menu (hold volume UP and power) you can see the updates are failing because of the wrong version but no legitimate source seems to be available from meta. Im getting frustrated as Ive been at this for hours now with no progress.

  • I also once in a while get a quick flash of the startup screen, although it's usually when I turn the headset off. I've put it down for a few days but I'll definitely have to look into seeing Thank you.

SPNFamily
Level 2

 The screen goes back right after the MetaQuest screen and the controller’s vibrate and then nothing. It is showing the unlock pattern on the phone for a second and then black screen on my phone and headset. 

ckjohnsons
Level 2

Did you ever find a solution to this? I’m having the exact same problem right now. 

Unfortunately not. 

So did it just die for good? Never used it again?

That was the case for me, as I haven't attempted to fix it anymore since over a month ago. I hope that's not the case for you though. Maybe you could attempt to get a replacement from support?