Showing results for 
Search instead for 
Did you mean: 

Quest 2 can't transfer data over USB

Honored Guest

On v.62, Over the weekend data transfers on any USB cable has stopped functioning, i've tried 2 different cables, 2 different computers and a rebbot. Power is still being connected and i sometimes get the USB promt, but it just disconnects immediately. I've had the headset for about 2 months now and while i've had with USB-debugging before, i've always been able to access the onboard storage on the quest 2.

I've tried some of the solutions in this thread but it hasn't improved anything.

I have been able to connect the headset to a pc via CX file explores "acces from network" feature but it is more cumbersome than just connecting a USB cable.



Community Manager
Community Manager

Hey @metaquestpc, thanks for reaching out in regards to being unable to use the data transfer cables you own to manage the onboard storage for the Quest 2. We can understand how this would impact your ability to access the onboard storage for your Quest 2, especially when you just want to use a simple plug in method to manage the data, instead of using the Access from network feature in File Explorer. 

We have a couple of things we want to check out and verify on this end to help get your onboard storage available again:


  • Ensure that the headset is up to date by checking for an update manually
  • If you are able to update to Version 63.0(the most recent version that is available) and this does not resolve the data management issues, try using Version 64.0 PTC instead here.
  • Try using the default cable that comes in the box with the Quest 2, or a Quest Link cable specifically if using anything else

If there are still issues after trying the above steps, please get back to us with some additional information:


  • The types of cables you are using(photos can be provided as well!)
  • Do other functions of the USB port on the headset still function normally, like charging or using it for quest link to use for PCVR, such as the light on the headset appearing and if it does, what color is the light when plugged in, or does it disappear and reappear

    Please let us know if these steps were successful in help resolving your current issue! We're here to help!
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

Hi @metaquestpc. We just wanted to check in and see if you've managed to find a solution to your data transfer issues. If you still need any assistance, we're more than happy to help. And if you've already found a solution, feel free to let us know too.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?