cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 doesn't hold a charge when playing pcvr with link cable, audio issues, disconnecting issues.

Baconator_No_Bacon
Honored Guest

My link cable and the quest link in general has become a pain in the ass to use for some reason out of nowhere. I've had this cable for quite a bit which could be a reason why its terrible, but its so unbearable even trying to play a game with it. Recently I got a new pc and for some reason i guess the cable dislikes the changes, almost all of these issues I'm going to list have never happened on my old PC. First of all, it has connection issues, which its always had since I bought it, but have progressively become more and more frequent and problematic, then on top of that when I eventually by the grace of god somehow get it to connect to the pc and I'm in the link menu, more problems arise. I get in and play a game and realize I have no audio, at all, not even the link menu is making sounds as if the headset is muted (its not), when testing with other not for quest 2 cables just to see if it would work, the audio works on those cables for some reason? Then on top of THAT the headset barely holds a charge at all when playing pcvr games while plugged into the pc, it doesn't even charge the quest 2 at all which im pretty sure on my old pc it does charge or atleast maintain a battery level and has enough charge to stay alive until I play the hell out of it or until i get off which is a good couple of hours and then has enough charge to play standalone for a while if i wanted to, I wish that was the case for this pc because the headset doesnt even charge when connected to the pc at all, not even while off. one time I left it completely off while plugged into the pc and it didnt even go up a percent, it actually went down one after like an hour of leaving it there, and this sucks because by time i find a manageable way to play the game, I only have like ≤ 50% battery left which with the issue of the pc not being able to keep the quest 2's battery up only gives me maximum on a good day about an hour of play time and its just not enjoyable. maybe the community can help. I already contacted support about this which didnt really help. crazy I paid 80 dollars for this cable..

11 REPLIES 11

MetaQuestSupport
Community Manager
Community Manager

Hey there, @Baconator_No_Bacon. PCVR is a great way to explore the VR playing field. We always want to ensure that our users can enjoy PCVR just as much as they enjoy using their headsets in standalone mode. With that being said, we are more than happy to see if we can get to the bottom of this issue and get you back in the VR world. We do have a few questions for you, just so we have a better idea of the issue.

 

  • Can you please share the specs of your new PC?
  • Is your headset up-to-date? (You can always ensure that your headset is up-to-date by following this link here.)
  • Did this issue happen before getting your new PC?
  • Have you tried any kind of troubleshooting to resolve the issue?

Once we have these answers, we can proceed with some troubleshooting. Thanks for working with us, and we hope to hear back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hello again, @Baconator_No_Bacon. We just wanted to check in with you and see if you still needed help with the PCVR issues you were having. If you still need assistance, please feel free to reach back out to us at any time! Have a great day!
 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Specs:

  • CPU: AMD Ryzen 9 5900X
  • GPU: ASUS Dual GeForce RTX™ 4070 OC Edition 12GB GDDR6X
  • 32 GB RAM (2x16GB) Corsair VENGEANCE RGB PRO
  • Motherboard: TUF GAMING X570-PLUS (WI-FI)

 

  • My headset is always up to date and always usually is up to date when these issues occur.
  • The only problem I had before getting a new pc was slight disconnects here and there but no major issues. It was always able to keep a charge long enough for me to finish my session, but the new pc just can't. It always dies during gameplay. And like I mentioned, the pc does not charge the headset at all, even when its off. This is my main confusion because the old pc was able to charge the headset perfectly fine, If you were to leave the headset plugged in and off on the old computer, It would actually charge up. On the other hand, this current pc does not charge at all, the percentage on the headset doesn't even go up one percent at all, even when left on charge for an hour.
  • I've tried pretty much everything, I feel like there's nothing I have not tried. I've tried all the obvious things, but there might still be some things I haven't tried.

Hi again, @Baconator_No_Bacon. Thank you for sharing that info with us. After taking a look at your answers, we wanted to ask you: with the methods you tried to resolve the issue, was a factory reset among those methods? If you have not, we think this would be a good place to try. You can find the steps to perform a factory reset here, if you need them. Please remember to save your progress by enabling Cloud Backup. If you have already tried this and it did not fix the issue, we ask that you please send us a PM so we can assist you further. To do so, please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I in fact did not attempt a factory reset and I probably should do that, I will do that now and play some games and see how that works out.

Sounds good! Please reach out if you are still having issues. We would love to help you out!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Well I tested it out and there seems to be no changes and appeared to be draining at about the same rate at it usually does. And I also left it plugged up to the pc to see if it would charge overnight, didn't even go up a single percent. I'm really confused about that because the port should be supplying enough power to charge the headset when its off, so something has to be wrong.

Hey again! We can empathize with you and know how inconvenient this must feel especially after your device use to charge on your old computer. Here are a few things to note:

  • Computers typically provide less power than outlets and may require more time to charge.
  • If the customer is using an adapter, the port type being used may provide even less power than the USB-C port that is typically used for charging and Link cables.
  • Computers may also stop charging peripherals if the peripheral is completely powered off (causing the computer to not recognize the presence of the device), or if the computer itself goes into a sleep state. This is defendant on the port, motherboard, BIOS settings (not all of which may be visible in every BIOS) and USB power settings. BIOS settings vary greatly between computer models, so we cannot provide assistance with these.
  • While in use, the headset will typically consume more power than the computer port can provide, resulting in the battery charge decreasing over time. The headset must be off or in a low power (sleep) state to charge.

Have you tried charging the headset with the charging cable that came with the device in a wall outlet? This may possibly yield a different result. Also make sure to remove any third-party accessories.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Unfortunately, I lost the actual charger that comes with the Quest 2, but my phone charger works just fine so I use it. I don't know where the charger would be, I lost it a while ago so I wouldn't really know where to start looking. And I also tried using my phone charger cable to plug in the Quest 2 to my pc to see if it would charge, In which it did, which makes me think it might be an issue with the cable. But I made an interesting discovery, I booted up the old pc and plugged in the link cable and played some games on it and the battery on the Quest 2 seemed to be decreasing at a very slow rate, and by time I got done playing, which was about at least 30 minutes if not an hour, it was at 96%. About that much playtime on my current pc would leave me at maybe 60% or maybe more. And I also tried to see if it would charge the headset, so at 96% I disabled link, powered off the headset, and left it there for a couple minutes. After a few minutes went by I checked the headset's battery and it was 98%, it's charging with the link cable. Now this leads me to believe its an issue with my PC now.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?