cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 has poor performance with wired link connection vs airlink connection for Steam VR

Viking__Plays
Honored Guest

Hi everyone,

so i got myself a Quest 2 a couple Days ago, mainly for trucking and flying via SteamVR

My Problem is, that the wired link connection is horrible. Everything is laggy and the screen looks like liquid, as soon as i move my head (no idea how to explain it otherwise).

On the other Hand, using SteamLink to connect via WiFi gives me way better performance even though my PC is connected wireless to the Router. But going WiFi, obviously results in micro stutters and lower resolution.

I have a 5 Meter HighSpeed Cable from Amazon and the connection test via Occulus Link gives me a constant 2.8 gb/s on USB3 and also with an adapter on USB-C.

I tried all sorts of solutions found online incl. the debug tool, but nothing helps.

 

Does anyone here can give me a helping hand on what i am doing wrong?

Thank you!

17 REPLIES 17

MetaQuestSupport
Community Manager
Community Manager

Hey @Viking__Plays! We would love to help you with your Quest link. We are so excited that you are now apart of the cool VR world. We totally understand how it can feel when you're ready to enjoy PCVR and are experiencing stuttering. In order to get a better understanding of what is causing this, we would like to ask some additional questions.

 

  • What error messages, if any, do you see?
    • What is the exact error message that they see?
    • If there are no errors, what is the exact behavior the customer has experienced?
  • Has a device ever worked before?
  • When did you first notice this behavior?
  • Has anything changed since you  first noticed the behavior?
    • Did any of the devices (phone, headset, PC) receive any updates?
  • What has the customer already tried?
    • If applicable and available, have you tried another device?
  • Is your PC compatible?
     

We look forward to hearing back from you soon! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hey, we wanted to check back in here to see if you still needed any assistance. Please don't hesitate to hit us up!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Viking__Plays
Honored Guest

Hi Support Team,

yes the problem is still there.

To answer your questions above:

- There were and are no error-messages.

- The Device has worked and still works fine.

- I noticed the issues from the first moment on, when i used Meta Quest Link to connect to my pc and started a game.

- Nothing has changed since then

- When i turn off the device, the headset always shows the message "Updating" for a few seconds before it shuts down.

- I tried multiple solutions that i´ve found on various platforms, such as trying different settings with the Occulus debug tool, trying different settings within the Meta Quest Link app on my pc and even changing the graphic settings within different games from low to high and back.

Nothing has solved the issue so far.

 

Yes, my pc is compatible with 16gb DDR4 RAM, a 12th Gen intel i5 and a Nvidia RTX 3060 with 12gb.

 

As i stated before, i have no issues using AirLink and Steam Link to connect to my PC, other then the WiFi limitations.

The Problem only occurs when connected via cable, even when it shows a stable 2.8 gb per second connection.

I simply don´t know what else to do, or where else to look for settings and/or solutions.

Hey @Viking__Plays, thanks for taking the time to reach back out with that info! If everything works just fine when you aren't using the cable, that sounds like the weak link and is likely the cause of what you are seeing. We would recommend making sure there are no adapters or extenders being used, go directly from a USB port on your PC's motherboard to the headset. Try multiple ports to see if one of them works best, and if you continue to see the same thing, try a new cable. Make sure that if you are not using an official Link cable from Meta, get an active USB 3 cable (an active cable will maintain its signal's integrity better than passive over the longer distances required for a link cable).

 

Hopefully this troubleshooting helps narrow down the cause of the issue!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey, we wanted to check back in again to see if you needed any further assistance. Please let us know!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Viking__Plays
Honored Guest

Hey there,

I´m going to test my USB3 Ports this evening and report back tomorrow.

it´ll need some time to get a new cable, since they aren´t exactly cheap, when it comes to active high speed cables.

Sounds good, @Viking__Plays!

 

We can't wait to hear back from you tomorrow. Thank you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @Viking__Plays!

 

Please update us whenever you get the chance to test out the USB 3.

 

We eagerly wait for your response! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Viking__Plays
Honored Guest

I checked all my remaining ports (4 that aren´t currently in use) but the result is the same.

 

I hope you don´t mind me saying this:

I don´t see how changing the cable will help me. My current one has a stable 2.8 gb/s transfer (checked in the Meta Quest Link app) and no matter which ones i look up online, they´re all around the same transfer rate, Not a single cable, including the active ones, get´s a transfer rate over 3 gb/s. Not even the official Meta one, which unfortunately seems to rank on the lower end of the lists.

But to not let anything untested, i will check a different cable as soon as i have the chance to get one.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?