Showing results for 
Search instead for 
Did you mean: 

Quest 2 link charging but not working with quest link

Level 3

So I just bought this $80 fiber optic USB type C to USB type C because my last one stopped opening quest link. I plugged it in with the oculus app running on my pc and there's absolutely no connection whatsoever. No green circle next to my device in the devices tab, nothing.  I saw that it was charging my quest but no prompt ever came up that said "Do you want this device to access your files on your PC?" like it would usually do with my old link cable.  Also take note that my old link cable was a USB type C to USB type A.

Any help?


Community Manager
Community Manager

Hey @OfficialSalad! Link issues are always a pain in the butt so we'd love to lend a hand! 


To gain a bit more insight/information, could you answer the following:


  • When was this first noticed? 
    • Did anything change around this time?
  • Is this the official Oculus cable, or a 3rd party cable?
  • Have you tried any troubleshooting?
    • Could you list it out to not have you repeat anything?


Along with this, there are a couple of things you can test out:


  1. Check your USB power settings:
    • Open Device Manager.
    • Locate the USB ports - Expand the universal serial bus controller section at the bottom of the list. Look for the "USB 3.0/3.1/3.10 eXtensible" items.
    • Right click and select Properties.
    • Navigate to Power Management.
    • Ensure that the options to save power are deselected.
      • They won't all have this and that's fine
  2. Check for Selective Suspending:
    • Right-click Start
    • Click Power Options
    • Click Additional Power Settings
    • Click Change plan settings
    • Click Change Advanced Power Settings
    • Find USB Settings
    • Make sure that Selective Suspend Setting is set to Disabled, and not Enabled.


Let us know if this seems to be of any use, looking forward to your update!

Community Manager
Community Manager

Heyo again, @OfficialSalad! Just checking in to see if anything provided seemed to help out.


If not, feel free to reach back out anytime for some further options! 

sorry for not responding, i accidentally forgot about this post and have already set up a time where im going to return the cable. But ill try that and see if it works.

That's alright! We know life can get busy, and we're always here for you!


And definitely keep us posted on if you try those steps we suggested! Let us know if they work or not.

I have checked the AMD USB 3.10 eXtensible host controller and theres no option for "power management".

I have also checked my USB settings and selective suspend settings is disabled.

I first noticed this when my old cable stopped working,

I bought a new cable which was USB-C to USB-C instead of USB-C to USB-A,

it is a 3rd party anker cable,

I have tried and nothing has helped,

and I dont remember any of the troubleshooting steps I did so far.

Good to hear from you today! Thanks for that update as well. 


It sounds like you may have purchased a charging cable. We recommend using the Anker USB 3.0 cable. Are you sure you purchased a 3.0 cable?


Let us know.

its a USB 3.1 cable, does 3.1 only charge?

A 3.0 and a 3.1 wouldn't be too too much of a difference but 3.1 is faster in terms of power management and data transferring so it could just be providing just a bit much juice to read right.


Do you know if you are able to run Air Link by chance? (Also, be sure the option is turned off in the headset just in case)

I can run air link and it’s what I’ve been using ever since my old cable broke. The unfortunate thing is that it’s pretty bad.