Showing results for 
Search instead for 
Did you mean: 

Quest 2 losing tracking -> forgetting guardian all the time

Level 2

I'm in a bright room (living room) and just playing when suddenly the screen turns black and it says the headset lost tracking.. after 2 secs it recovers but it can't remember the guardian so i have to redraw it... and that happens quite a lot, around 1 time every 15mins.
Is this just standard? Or is there a way I can fix this? I'm new to VR


Level 2

I noticed mine did this when I wore a certain pair of glasses or if the room I was in was too bright. I don't have problems if I'm in a room with 100W yellow lights. 

Hey there, @Battlevader0! Welcome to the wonderful world of VR, we hope you're enjoying it so far! 


The reason you may be having tracking issues and having to reset the guardian so frequently is because of the lighting, just as @AprilSchuSchu kindly said. We do recommend using your headset in a dimmer-lit room, as bright lights are not good for your sensors, which can be sensitive to light.


Try to play with your lighting and see what works best for you! You can also try to clear your guardian cache. We'll list the steps for you below:


  1. Press on your right Touch controller to pull up your universal menu.
  2. Hover over the clock on the left side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel.
  3. Select Settings in the top right corner.
  4. Select Guardian from the left menu.
  5. Select Clear Guardian History.


We hope this helps your issue. If not, you can always reach out to us here and we'll gladly help you out!

I managed to find the issue using the passthrough view, as the cameras do struggle with bright lights I figured that must be the issue why the tracking is interrupted.

As for the guardian issue, that might just be software. The headset (sometimes) does not recognize the area if it lost tracking for 2 secs, which is weird and probably should not happen.


But thx anyways, the tracking problem was far more annoying and I got that fixed now. 👍

My headset says lost tracking i have control for 1 second and no longer 

i have watched 3 tutorials on how to fix it and so far nothing!

i need help


Hey there, @Yaseenw! We definitely understand how stressful it can be when you lose your tracking and end up unable to play. We'd be glad to help out however we can! Could you send us a PM so we can work on this with you? Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. We'll be looking forward to hearing back from you! 

Hey there, @Yaseenw! We just wanted to check in since we haven't heard back from you yet. If you'd still like help with this just let us know, we'd be glad to help out!

I'm having a similar issue, camera flicking and losing tracking, keeps resetting back to guardian mode to set room but will flicker then go back in a loop to set guardian, flickering is approx every1 second so I'm unable to set a boundary stationary or guardian , I can see the cameras losing the controllers and my hands then it flickers back. Very frustrating.

Hey there @Matt.grasser.589! We completely understand how it feels to have issues setting up your guardian. There are a few things we can recommend which we will list below:


  1. Make sure the play area isn't too bright.
  2. Make sure there aren't many windows mirrors in the play area.
  3. Make sure there is no direct light shining on the tracking cameras.
  4. Try a different play area.


Once you have tried these steps please reach out to our wonderful email, chat and callback support team, as we have access to more tools through these channels that can help us assist you in a more robust manner. Thanks!

I'll reach out,  it's still not working following a reset.