Showing results for 
Search instead for 
Did you mean: 

Quest 2 not connecting over Link Cable

Honored Guest


I know there are multiple threads about this issue but none of the suggested "workarounds" seem to help and given this is such a common problem, with so many variables to the connection chain I thought it best to report this properly (rather than a +1 type reply to someone else's thread).

A few weeks ago: Everything was working fine.  Quest 2, Kiwi Design USB-A 5m cable.  The most I ever had to do to get a stable Link connection was to restart my headset.

Recently updated to Windows 11:  Link cable no longer works despite multiple attempts at resetting the cable, restarting headset and PC in different order, checking software versions etc.  I received a new USB-C/USB-C cable this morning to make sure the headset was plugged into it's very own USB rail and still nothing.

The link cable itself is working as when plugged in the headset indicates that it is charging, and the "Oculus XRSP Interface" item in device manager disappears and appears when I unplug and re-plug the cable.

However when I try to connect within the headset it continuously "searches for PCs".

Windows 11 Pro Build 22621
Oculus App Version: Stable 56.1
Quest Software V
Connecting via a 3m Kiwi Design USB-C/USB-C (5m USB-A/USB-C cable has similar results) directly to a USB-C 3.2 port on a ASUS ROG STRIX Z790-E Gaming Wifi with nothing else connected to this rail.

I know this is probably going to result in yet another round of "plug this in, unplug that, restart this, restart that" which I have gone through in the past.  An actual long term fix would be appreciated.

PS:  I should add that linking via Wifi is ok for a while but is horribly unreliable (despite sitting/standing 3m from a 5GHz router) and is not fit for my primary use which is simracing.


Accepted Solutions

Honored Guest

What worked for my was enabling developer mode for my quest, its kinda a process, you have to use the mobile app. 

View solution in original post


Honored Guest

What worked for my was enabling developer mode for my quest, its kinda a process, you have to use the mobile app. 

Honored Guest

Thanks man.  So I followed all the steps to enable developer mode (supply credit card info to Meta so I can pay for nothing, set up two-factor auth and supply a phone number..... which surely facebook already had) and guess what?  It works!  For now....

Now THAT is a ridiculous solution and I'd like to hear from Meta about why that works and what the problem was to start with if that's the process one has to go through?

So if someone from Meta happens to come across this thread I would appreciate a thorough explanation and some commitment to fixing this problem that doesn't require me to sign up to a developer program to simply use your product. 

I won't mark the above reply as a solution since this is at best yet another "workaround" and not an actual solution to the problem.

Thanks again @FluffyDoge