Showing results for 
Search instead for 
Did you mean: 

Quest 2 not connecting to Oculus phone app -SOLVED-

Level 4
This is what happened to me just now, so here's aheads up to those who are trying to get their brand new Quest 2 to connect to their phone.

In my case, I already had the app on my phone because I also have a Go and Rift S. I tried connecting through the app by adding a new headset. However, the app only offered the go, Rift S and Quest options, and so I tried connecting using the Quest one. The problem is: The quest 2 really needs the Quest 2 option in the app, and the app doesn't seem to automatically update to include the quest 2 option.

The solution: Uninstall Oculus app from your phone, and reinstall it. Then go through the connection procedure again using the now included Quest 2 option, and Bob's your uncle!

Good luck and have fun! It seems the Q2 really is a nice headset, though I still have to get used to it's shape a bit, and it also seems to be a bit more like everything is a bit more 'bendy' when you move your head around, like looking through a fishbowl. Turns out the Rift S does this too, but possibly to a lesser extent.

Anyway.. enough of my ramblings..

Volunteer Moderator
Volunteer Moderator
Good to know. I had an update to my iOS phone app yesterday, but it still doesn't show Quest 2 in the Pair New Headset section. If it hasn't sorted itself out by the time my headset arrives tomorrow, I'll uninstall and reinstall.

i7 5820K @ 4.25GHz | RTX 3080 Ti FTW3 | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32GB | Corsair HX 750W
SSDs: Intel 660p M.2 2TB, 3x Samsung Evo 1TB | Startech PCIe 4x USB 3.0 | Startech PCIe 2x USB C 3.1 gen2

Level 4
Has anyone had this issue with your quest 2 not showing up on your phone but your quest 2 is already setup?

Did you ever hear anything about this issue? It's been driving me crazy for about a month. My Time Zone in my Quest 2 is off as well, even after a factory reset so I'm thinking it has to due with this.

i have the issue but how to repair