cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 not connecting to phone, even after a factory reset

MiniHaymer
Honored Guest

IMG_2739.png

About six days ago my quest 2 suddenly stopped syncing, connecting to my iPhones app, i couldnt cast, edit settings or do anything with it, so i tried a few of the troubleshooting steps and they didnt work, so i factory reset my device and now im stuck at the point where you need to connect the mobile app with the vr but when i enter my code again it doesnt connect. Any help would be appreciated so i can get my vr working would be much appreciated. Thanks

12 REPLIES 12

LaserDisk
Meta Quest Support
Meta Quest Support

Hello there, @MiniHaymer! Welcome to the forums! I see you're having some trouble with your device right now, but don't worry. Once we figure this out, I hope you decide to stick around and join our amazing community.

I've actually experienced this issue twice since I switched to iPhone. Both times, I was able to resolve it by following these steps:

Make sure your phone is up to date, delete the Meta Quest phone app, and factory reset your device. When you're setting up your headset again, make sure to completely power off your phone and then turn it back on. Lastly, try connecting your headset as if it's the first time.

The future of home entertainment!

Thank you for the advice, I just tested it but it did not work. Im stuck with the same not being able to connect the device screen or it goes in an endless loop of me typing my 5 digit code in to pair it up after factory resetting. If you know what else i could do i would be very appreciative.

This method is a bit rough and may need 1 or 2 tries. First, factory reset your headset again, but this time put in the pairing code into the app before you finish the setup video. If you have any other phone or tablet around you can use for setup it may also be worth giving it a try.

The future of home entertainment!

I tested that just now and it did not work either, it was just repeating the type the 5 digit code in and didnt say anything after i did, it just continued to find the device and ask for a code

Did you try entering the same 5 digit code or did it require a different code in a separate location? Were you able to attempt connecting to a different device?

The future of home entertainment!

MiniHaymer
Honored Guest

I did the same 5 digit code and it kept looping back to looking for headset and asking for the code again

Try turning on your phones mobile data and connecting using that, I want to try and rule out any internet issues.

The future of home entertainment!

So i tried that just now and it repeated the loop still, i could restart the router but im pretty sure that isnt the problem 

Do you have all permissions enabled on the phone app? Have you cleared your Bluetooth cache yet?

The future of home entertainment!