Showing results for 
Search instead for 
Did you mean: 

Quest 2 not working with acer nitro 5 an517-41-r48y

Level 2

Hi everybody!
just bought this very nice laptop(ryzen 7,rtx 3060),equipped it with 32gb of ram only to find that it doesn't work with the quest 2 
both with cable or air link,the result is the same: the 3 loading dots stay there forever

sometimes i get the general error message,mostly not

it worked with my old desktop(ryzen 5 and an old r9 380x) but obviously was really slow and full of glitches

does anyone solved this issue?

what's the point of having the quest 2 if i cannot connect it to a latest generation laptop....


Hey there, we know how frustrating it can be when connections don't go smoothly! Worry not, if you still need assistance go ahead and open a support ticket with us here and if you would please include the log files when opening the ticket. We'd be happy to help out with this issue!

Level 2

Installed latest drivers from nvidia and had the same problem. But then installed latest drivers from AMD (adrenaline) and it works now.