cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 pro controller tracking issue

HappyHunter991
Honored Guest

I have the meta quest pro controllers on the quest 2, I have owned them since Febuary now. They were working just fine last night and now for some reason it says they need an update and it won't even start that controller update. The lights just stay white as if they are not even trying to update. To make matters even worse is the fact that they just won't track. No matter what I do they never wanna track, I tried cleaning, rebooting, un-paring then re-pairing. Nothing sames to work

8 REPLIES 8

ForemanDev
Protege

I JUST ran into this exact same issue also! My Quest Pro controllers are no longer tracking. I'm using them with my Quest 2. All of a sudden I got an in-headset notification that the controllers are updating but the lights on them are solid white. I can get the controllers to connect but they don't track in 6dof - I can only rotate them, which is unusable. Was a new update just pushed that broke things? @MetaQuestSupport 

Brass_Angel
Honored Guest

Looks like update 57 broke the Quest 2's ability to track the Pro controllers. It detects them but the range of movement is similar that of Quaid's from the first Total Recall. Tried unpairing, rebooting, updating... nothing. And since my Q2 controllers are broken and very few apps work with hand tracking, I have a pretty paperweight until U58 comes out.

hawkbatman06
Honored Guest

I’m having the same issue I also made a post about this same thing.

lewiscon
Explorer

Hi I am having the same issue pro controllers keep loosing tracking, and now when turn on headset quest 2 then keep getting a controllers updating but doesn’t go any further, I have tried all forum suggestions of resetting controllers, putting on charger and resetting headset, disconnecting them on the app and reconnecting but even after 24 hours still getting same message. I have now reconnected old quest 2 controllers and they are working fine, as someone else has suggested maybe an update on headset has messed up using the pro controllers, hope it’s fixed soon as they were a birthday gift and sad cannot use at all.

MetaQuestSupport
Community Manager
Community Manager

Hey there @HappyHunter991! Controller issues are never fun to deal with, and we're here to help you get this sorted out as soon as possible! If you haven't already, can you try removing the batteries for 15 minutes and then re-inserting them back into the controller? This should trigger the controllers to go through with the update. If you're still having tracking issues after updating the controllers, you can try recalibrating your joystick range and deadzone: 

  1. ​​From your headset, select Settings.
  2. Select Controller Settings.
  3. Under Joystick Deadzone and Range, select the joystick you're having an issue with.
  4. Follow the on-screen instructions to recalibrate the joystick deadzones.​

Please make sure the joysticks are resting in their neutral position when you turn them back on. We hope this fix worked for you, if not, we can continue working through this together!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

This is an issue lots of other people are having including me, people using pro controllers with the quest 2 since U57 the controllers won’t track and just says updating, this issue Is to do with the software, we hope you find a fix.

Hello @Jed_VR25! We know how concerning it is when your controllers don't update properly. Not to worry, we're here to lend a helping hand! Can you confirm if you've tried the steps previously provided? Can you also try to unpair and re-pair the controllers, then do a restart to your headset? After this, you should see the controllers begin the update. If you don't see any improvement, please send us a PM, so we can take a further look into this. To send us a private message please click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there @HappyHunter991 @Jed_VR25! We're checking in to see if you all still need assistance with your controller issues. If so, please reach back out and we'd be happy to help! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!