cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 stuck in USB UPDATE MODE!! Please help!

Qupo
Explorer
So I just updated to the newest version 23 around noon, spent a couple of hours playing Half-Life Alyx till the battery is very low. Turned off the device, charge it. And then tonight I unplugged the charging cable, and I notice that the sidelight doesn't turn off automatically and the light is orange instead of green for some reason. So I decided to take a peek and the screen is somehow ON and it just says USB Update Mode.

bv901mmsepnw.jpg

I have 5 options available on the Screen: Boot device, Device Info, Factory Reset, Sideload Update, Power Off.

None of these options work:
-Boot device would just restart the quest back to this very same screen.
-Device info just shows info of the device like serial number, Ram Size, etc.
-Factory Reset would just restart the device back to this screen just like what the Boot Device option did.
-Same with Sideload Update, it just restarts the device.
-Power Off would turn off the device. And if I turn it back on, I get the same USB Update Mode screen.

I'm at a loss here, is there a fail-safe to force Factory Reset the device? I'm seriously in need of help, I don't have the luxury of just sending the device back, unfortunately. Does anyone ever have the same experience? How can I get past this USB Update Mode screen? Thank you kindly for your help in advance.
49 REPLIES 49

elzorro1219
Honored Guest

wow! this happened last Saturday November 19th, 2022 and I have no found anything to help us to fix. I contacted support but i haven't hear from them.

Honestly, it shouldn't of costed you anything to return it for a fix/replacement. The RMA should of been approved and a shipping label sent to your email for you to print out and just about any small box the device would fit in would work. The postage is supposed to be paid by them. Being that this is a known widespread issue, even out of warranty should of been covered for an RMA at least once being it was due to no fault of your own. I have an old 64gb model that you can't even buy on amazon anymore and is out of warranty that got an RMA approval due to a now fairly widespread and known charging bug where it gets *stuck* charging at random percentages. The going window of percentages are between 51, and 58%. I haven't sent mine in yet as of this writing..it's the 18th of December, 2022 and I know yours is an older post, but I just had to comment on this just in case I could lend some info to you. Why was it going to cost you more than the quest's price, anyway? That's crazy. If they are going to keep going in a crappy direction as that, This business model  is going to keep suffering. The current quest pro that is coming out for 1200 to 1500 usd is ridiculous and kinda puts me into a frame of mind thinking the pro is meta's *ACTUAL* vr device, with quest and quest 2 and their users being their test model and us being test subjects for a not-so-cheap beta run. Just a thought. lol (I should also note that mine was among the first to early quest 2 models and aside from the charge bug, it still runs super smoothly like a brand new one, but I am hesitant to send it in due to some horror stories I have heard from people about meta's rma practices. Stories such as sending one in, and it getting lost, or they said it would be a free fix/replace and wind up they wanted payment and would not return it until said payment was made..to right out cutting contact with the customer and no other customer support could help because the ticket or ref number didn't exist or was marked as resolved. It's enough to make you cringe and put the brakes on any idea of taking your chances and rolling the consumer vs corporation dice.)

2023, still the same problem. First I only saw the usb-menu. I rebooted the quest 2 with this menu. Now I can enter at least my virtual environment - but I still see the USB message floating around. Additionally, I can not access my desktop. Or, to be precise, I can. It is just that I can not move while looking at it, the desktop will black out immediately.

Hi there, @Moredread1! That certainly sounds inconvenient to run into, so we'd be glad to lend a hand with that USB Update Mode issue! We appreciate the troubleshooting you've completed so far, and have a few things that may help us narrow down the possible cause to this issue. When you get the chance, please go over and answer the following for us:

 

  • Is this issue happening only while the headset is connected to your PC, or does it also persist while the device is in standalone mode?
  • Has the headset been recently connected to the Meta Quest mobile app, and fully charged? 
  • When the device is in standalone mode, are you able to try using the volume and power buttons on your headset to complete a Factory Reset? 
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Howdy, @Moredread1! We're checking in to make sure you were able to get that Quest 2 display issue fixed, or if you've run into any further trouble with that at all. No user should have to deal with a stuck screen like that, and we want to make sure everything went smoothly for you along the way. Please don't hesitate to reach back out with those answers, as we'd love to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

shanerecon
Explorer

 I’m experiencing the same issue after updating the firmware or software update on the oculus Home Screen 7 months ago ,to my understanding there is no fix available yet,I’ve tried selecting boot device in the usb update mode,it brings me back to the same usb update mode screen,I’ve tried factory reset,it brings us back to the same usb update mode screen,same for side loads and power off option. Device info show it serial number and lock state:locked,whatever that means.but most likely is a software issue.

IMG_1633.jpeg

IMG_1631.jpeg

IMG_1632.jpeg

Hey there, @shanerecon! We see your Meta Quest 2 is stuck in the USB update mode. We're here to make sure your VR experience is as smooth as butter, so we're here to help! Since you have already attempted all the required troubleshooting steps, we kindly request you to send us a PM so that we can further assist you. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @shanerecon! Just checking in to see if you are still needing assistance with being stuck in USB Update Mode after trying the troubleshooting steps provided. Please reach back out if you need to continue working with us on this issue. Thank you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there @shanerecon! If you do still need assistance, we want you to know we are still here if you need us. Please let us know and we will be more than happy to assist you with this! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I've got into the same problem. Any troubleshooting steps from this thread didn't help. 

The device was connected to the mobile app before. Previously it was connected to PC as well. After update I stuck in the USB update mode loop. In Device Info menu from USB update mode I can see that the current boot slot is B, so I assume the problem with the Update Mode loop prevented automatic rollback to boot slot A. I checked more specialized forums and spaces to see if I could manually update the firmware from the PC, but I found out that because of the loop sideload update won't work and the device cannot be set in the correct mode for the firmware update.

If you have any algorithm to handle this USB Update mode or need more debug information please reach out to me

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?