Showing results for 
Search instead for 
Did you mean: 

Quest 2 won’t power on

Honored Guest

I haven’t used my quest 2 in a few months but decided to use it today. I tossed it on the charger for a few hours and when I went to power it on the screen was black with a flash of blue every 10 seconds. When I have it plugged in there is no indication showing that it’s charging or light on by the power button. I tried the same charger on another headset and it worked perfectly fine. I decided to leave it plugged in for 4 more hours just incase. And it still won’t turn on.

I am pretty disappointed because i haven’t had many issues in the past. 

is there any advice on how to fix this?


Community Manager
Community Manager

Hi there, @SPAGHETT1_! We'd like to do our best to get you back in the wonderful world of VR gaming, so we popped in to help with your headset! In order for us to get a better idea of what may be causing problems, please tell us, what specific charger are you using to charge your headset? Were you able to make sure the headset is fully powered off while charging? Also, are you able to load the boot screen on the headset to hard reboot the headset with the below steps? Let us know and we can continue from there! 

1. Turn off your headset. 
2. Firmly hold the power and volume down (-) buttons on your headset simultaneously for about a minute, or until the boot screen loads on your headset. 
3. Use the volume buttons on your headset to highlight 'Boot device' and press the power button to complete that.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!



let the headset on charger over night.

After a few month of not using/charging the battery might deeply drained.

After a night on charger it hopefully work again.
I'll keep my fingers crossed🤞

Community Manager
Community Manager

Hey there, @SPAGHETT1_! We noticed that we haven't heard back from you yet. We want to make sure that you are fully taken care of, so if you need anymore help with this, please feel free to reach back out! Otherwise, we hope you have a great rest of the week. Take care!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Heroic Explorer

@SPAGHETT1_   if lipo batteries go below a certain charge state, the charge protection circuit will stop allowing the battery to be charged.

If you repeatedly apply power to the headset by plugging and unplugging the headset charger to the mains supply, this can push a small charge into battery before the charge protection circuit stops the power. 

After a while it's possible to get the charge above the minimum charge state and charge protection circuit allows charging as normal.

Four Rift CV1s, Quest 2, Quest 3.
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?