cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 3/ Air Link stopped working/ No connection to PC/ PC found but Start Button is greyed out...

Playsianer
Protege

I've been using the Quest 3 for almost 8 months now, and before i used the Quest 2 without any problems via Air link/same router/same PC...


This Saturday I'm playing Borderland 2 VR and on Monday the Quest 3 can no longer connect to the PC without any reason.


If I want to activate Air Link via the Q3, my PC is displayed in the Air Link Menü as before, but the Start Button for Air Link remains gray and it says "not connected".


I've already tried everything:Hard reseting the Headset, factory reset, router reset, PC & Quest 3 reset, Meta Quest Link restart via the beta menu in the PC Oculus APP, repair function of the Meta Quest APP, firewall completely switched off but nothing...


Then I read that you should completely delete the Oculus software with all folders and reinstall it.
I did that and lo and behold it worked, for exactly ONE day....


When I booted up my PC today and started Quest 3, the same problem...
The PC is displayed but the start button to start Air Link remains gray and it is not connected.
WHY?
Do I have to completely uninstall the software every time, including all folders, then reinstall it in order to be able to play via Air link for exactly ONE day, which has worked for over 3 years before (Quest 1, Quest 2, Quest 3) without any problems?


The connection works immediately using the original Meta Quest Link cable.
Virtual Desktop APP works also...


PLEASE Help!

207 REPLIES 207

Posting logs is often a helpful method to diagnose many issues. However, the problem here is that the debug tool on the PC won't capture the errors originating from the headset itself unless the PC and headset are linked via ADB. Unfortunately, Air Link and ADB cannot be used simultaneously.

Additionally, Meta encrypts the Air Link data between the two devices, making it difficult to access. No amount of logging will reveal this encrypted data exchange.

The main point I want to emphasize is that this issue cannot be resolved merely through logging. The core of the problem is beyond the scope of standard log files and requires a different approach.


No i only have V66 on my Q3 and V65 on my Q2 but now i just checked for any updates on my Q2 ( which where are non ) and it seems that one has now forgotten its Airlink settings on reboot also.
Its a definite Meta issue and not user related.

YoWoRingo
Honored Guest

My Quest 2 also has this shows "No connection to PC" problem too, my Quest 2 info is:
Version: 65.0.0.547.341.596252018
Runtime Version: 65.0.0.549.344.596252017
It's also weird that if you reopen Quest Link, it'll match😑

Ye same thing as all of us i think. No doubt it will get sorted and at least we can re-connect its just annoying having to each time 😞
However no probs with Virtual Desktop or Steam Link so that's something 🙂

Silent_Koroshi
Honored Guest

So im having the same problem and everytime i try to headset to my pc it say that it cant connect. anyone know why?

qwertylesh
Explorer

This affects both Quest 2 and Quest 3 for v65 and v66.

Is this a problem with the meta quest app on the pc side? Downloading the software and choosing repair does not fix it, its very difficult to get the pin pairing sequence to start from within headset settings and then when I get into airlink, after exiting it acts as if the pin pair is invalid, greying out the launch button once again.

I hope Meta has put in the maximum effort to keep the people around who'll prevent attrition or further breakage, and who can actually correct this in a timely way. 

 

edit: theres some strange behavior where quest link service on the headset (in particular on quest 3) doesn't appear to load correctly. and the poor behavior seems to stem from that.

its not the problem from the PC app.. its the firmware from the headset. its dealing with the Trust Certificates.

Meta is taking their sweet time fixing it.

It sees my pc but it says "no connection",my pc doesn't see quest2 at all. 
I have to go to settings,turn off and on the link feature,re-enable airlink and then I can pair it with my pc. 
Then it works perfectly without issues till I restart my quest 2. 
I don't know why it does that and what causes it. I am new user of quest 2. Any help is welcome.

NomadsAnIsland
Heroic Explorer

Nothing has updated on my Quest 2 since the 12th except some apps. Problem with Air Link still exists.

This is a known problem that supposedly had a fix from engineering that was released on 06-13. No one seems to have gotten the patch or it doesn't fix the problem yet.

Given the track record of fixes for previous problems it will probably be 3-6 months before you see a fix, if ever.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?