Showing results for 
Search instead for 
Did you mean: 

Quest 3 Airlink will no longer connect to PC


Honestly regret buying this piece of junk. I purchased the quest 3 to mostly play PC VR games and it's been a nightmare from the get go.

At first I had no problems connecting via airlink but the signal was average and the performance was poor to say the least, even though I have a top of the line gaming router. I read that an ethernet connection was the way to go so I purchased a high end WIFI extender and plugged my computer directly into it. It took a lot of effort and finagling but I was finally able to get it connected and the performance was better but still not great.

About 3 days later (after the last major quest 3 update) it just stopped working. Now when I try to connect to airlink I just get stuck in a loop with the 3 little white dots at the connection screen. Software on the desktop says the quest 3 is connected and active but I'm still stuck in the loop in the headset. 

I've tried power cycling, rebooting, reinstalling oculus software and every WIFI configuration imaginable but I get the same result. All drivers and Windows 11 is fully updated.

I'm beyond frustrated at this point and really wish I wasn't past the return window. Support is non existent. No phone number to call or even a chat service. Very disappointed with this headset and Meta in general. 

I'm making a last ditch effort to see if someone on here can point me in the right direction. Any help is greatly appreciated.



Now it won't even connect to the PC over WIFI with ethernet out of the loop. At least that was working a few days ago. Air Link is an unmitigated disaster on Quest 3. 


Meta is killing things with their updates it wouldn't surprise me if its this months update thats causing you this problem 

It's completely broken. Every time I try to connect to my PC it opens the oculus app and then immediately crashes in the headset or just spins at the 3 white dot loading screen. I've tried everything. Reinstalling the oculus software, pairing the headset again, every WIFI setting possible and the same result.

This thing is worthless for PC VR and it's readily apparent that Meta gives no **bleep**s about this feature. Really regret buying this headset. 

Honored Guest

 meta quest 2 owner here! Been dealing with this issue for 7 months. Sad thing is I have tried to sell my headset but no one wants to buy it however I would still be interested in keeping it if this issue ever gets resolved. 

Hey everyone! We understand how important it is to be able to connect your devices using Air Link. We also know how this takes away from your VR experience when this feature is not working as it should. We would like to look into this deeper with you to resolve this issue. Please send us a private message so we can assist you further. To do so, please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. We hope to hear from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!