Showing results for 
Search instead for 
Did you mean: 

Quest 3 Walls or furniture saved as space settings are not visible on screen after PTC V64

I have a Quest 3 and this is my first PTC update. However, I am having a problem with 'Space Settings'. I never had this problem before the PTC update.
Scanning my room, adding furniture, and adding walls or windows works fine. It was also possible to name rooms, edit rooms, and modify furniture as normal.
However, the space and furniture set up this way are not displayed on my screen in the virtual environment. Previously, when I brought the controller or Quest 3 near a wall or furniture I had set up, it would appear blue, but now nothing is visible.
The problem is that the spatial data saved in the spatial settings remains. I repeatedly deleted and recreated this space, but it did not solve the problem of not being able to see it in the virtual environment.
Borders are saved normally and are visible. The option to change the color also works fine. However, only the border is visible, and no walls or furniture are still visible.
This feature was one of the most important safety nets to avoid getting hurt in the VR environment of my room. As I moved, I could see the blue output of furniture or walls and reset the distance or move in a direction that wouldn't hurt me.
I tried everything I could to solve this problem. I repeated clearing the space and rescanning dozens of times, resetting once through the phone app, and once through the device's power options, but it did not solve the problem. I still can't see any furniture or walls and this doesn't change whether I'm in a virtual or passthrough environment. The space is saved, the furniture and wall settings are also saved, but I don't know why they don't show up on my screen.

My request for help was written through a translator, so the terminology may be slightly different and I need your understanding. I hope the meaning was conveyed correctly, and I hope this problem is fixed quickly. Now that I can't see the walls and furniture, I'm scared to swing my arms or move my body while wearing VR. This is especially true because I have been bumped into and injured a lot even in environments where walls and furniture are visible.

Meta Quest Support
Meta Quest Support

Hi @BMO382, thank you for bringing up this issue with the Space Sense for the roomscale boundary. I I see you have already tried troubleshooting the headset and mention resetting it. Just for clarity, did you mean a hard reset or a Factory Reset? Please let me know as I hope to hear from you soon!

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

hello. thank you for the reply.
The 'Factory Reset' you sent as a link is correct.
I first performed 'reset', which is supported by the Android meta app. But it didn't solve the problem. So, after this initialization operation, I changed the ON/OFF setting of PTC channel update registration to OFF. However, even after setting up the device, my device was still stuck in V64. (The reason I say this is because I thought this would take me off the PTC update channel and back to the V63 version I was using previously.)
Afterwards, I kept repeating the space settings, but my controller and device body were still causing the same problem. (Even if I brought the console close to the wall or even put the controller against the wall, I couldn't see the blue color that can be seen when detecting a wall. In a pass-through environment, a virtual environment, or any other environment.)
The space I scanned and saved wasn't even destroyed. When I pressed the space setting button in the room I had previously scanned, it loaded up what I had previously scanned and was visible on my screen. Because of this, solving the problem has become more difficult. If it's a problem with the room scanned data, I can just scan it again and again. In fact, while using it, I often experienced the phenomenon of the space in the room I scanned collapsing, so I frequently scanned the space in my room. Imagine that the desk you set up yesterday turns out to be 10cm lower when you use it again tomorrow. I had no choice but to scan again.
Afterwards, I tried Factory Reset from the menu accessed by pressing the device's power button and volume (-) button, but the result was the same. Still stuck on V64, problem not resolved.

Meta Quest Support
Meta Quest Support

I'm sorry factory resetting doesn't seem to be helping. Since you're still on PTC v64, let me grab some info from you and relay all of this to the team.

Can you please provide me the following:

  • Which headset you're using:
  • Software Version Meta Quest Mobile App:
  • Software Version Meta Quest Headset:
    -  The full version like this "".


“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

I appreciate your and the team's support and response and hope this issue is resolved quickly.

Which headset you're using: Meta Quest 3
Software Version Meta Quest Mobile App: (Android)
Software Version Meta Quest Headset
-There are many versions. So I will list all the versions in order.
=>Software version: 49919070043300510
=>Runtime version:
=>OS version: SQ3A.220605.009.A1

Please let me know if there is any additional information you need me to share.

Meta Quest Support
Meta Quest Support

Thank you so much for all of that! I just relayed this info, so if I get any news, I'll be sure to update you on here.

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

Hi. I have the same problem today. What to do?(


I have the same problem as you. Were you able to solve it?

I remember there was an additional update for Quest 3 recently (about 17MB in size) targeting V64, and I applied that, but I still couldn't resolve this issue.
My guess is that this problem occurs because the 'individual space settings' that were added between V61 ~ V63 of Quest 3 are conflicting somewhere. In the previous version, there was only one slot to scan your room and save space, but with the update, a large number of slots were added. It was great to be able to save multiple rooms, including the game room, living room, and study area, but I started to experience a bug around this time where my space was falling apart. For example, I used it yesterday, and when I tried to use Quest 3 again a day or two or about 12 hours later, the space in the room I had scanned was warped or jumbled. This refers to a phenomenon in which the wall appears to have come down by nearly 10 cm, or the height of the furniture I set has changed to be 10 cm higher. No matter how many centimeters, it is important that it collapses.
However, this bug at this time could be resolved by rescanning the room, so I was temporarily solving the problem by scanning the room frequently, although it was cumbersome. In any case, not being able to see the wall properly raises safety issues.
The main feature of the bug I'm experiencing is that the Quest 3 wearer can properly display and check the circle or random 'floor space' centered around him or her. At the same time, the space in the room I scanned is not being loaded. In other words, I think the cause is that even though I am in space A, I am mistakenly thinking that I am playing Quest 3 in a space other than A.
In this case, a solution might be to play in a different space, but that's not possible for me. I don't have enough personal space to play Quest 3 except my room.
Once the problem is resolved, I'll be sure to leave it in my post. I hope your problem is solved.

Thanks for the answer. I also periodically had problems with walls and furniture moving. I also solved this problem by rescanning the room. But yesterday I installed the update, and today all the walls and furniture disappeared. Although they were saved in the settings, and new scans are also saved, but during use and games only the border circle on the floor is visible. I've already done all the factory resets and nothing helped.
Have you used the SideQuest app?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?