Showing results for 
Search instead for 
Did you mean: 

Quest 3 Walls or furniture saved as space settings are not visible on screen after PTC V64

I have a Quest 3 and this is my first PTC update. However, I am having a problem with 'Space Settings'. I never had this problem before the PTC update.
Scanning my room, adding furniture, and adding walls or windows works fine. It was also possible to name rooms, edit rooms, and modify furniture as normal.
However, the space and furniture set up this way are not displayed on my screen in the virtual environment. Previously, when I brought the controller or Quest 3 near a wall or furniture I had set up, it would appear blue, but now nothing is visible.
The problem is that the spatial data saved in the spatial settings remains. I repeatedly deleted and recreated this space, but it did not solve the problem of not being able to see it in the virtual environment.
Borders are saved normally and are visible. The option to change the color also works fine. However, only the border is visible, and no walls or furniture are still visible.
This feature was one of the most important safety nets to avoid getting hurt in the VR environment of my room. As I moved, I could see the blue output of furniture or walls and reset the distance or move in a direction that wouldn't hurt me.
I tried everything I could to solve this problem. I repeated clearing the space and rescanning dozens of times, resetting once through the phone app, and once through the device's power options, but it did not solve the problem. I still can't see any furniture or walls and this doesn't change whether I'm in a virtual or passthrough environment. The space is saved, the furniture and wall settings are also saved, but I don't know why they don't show up on my screen.

My request for help was written through a translator, so the terminology may be slightly different and I need your understanding. I hope the meaning was conveyed correctly, and I hope this problem is fixed quickly. Now that I can't see the walls and furniture, I'm scared to swing my arms or move my body while wearing VR. This is especially true because I have been bumped into and injured a lot even in environments where walls and furniture are visible.
106 REPLIES 106

I can guess what you are talking about.
Using the SideQuest app, you may also be able to move firmware versions by enabling developer mode. (Maybe) This process may not be as difficult as you might think, so I thought about looking it up and giving it a try. However, I haven't actually tried it.
Firstly, since PTC is a beta testing channel, we must admit that the builds are unstable. I'm waiting for V64 to be officially released to all Quest 3 users. In fact, the most notable change from V63 to V64 is the improved resolution of the passthrough, which means there are software changes to the external camera. Perhaps, an unknown bug may have occurred during this process. I think it's worth waiting until the official update. Randomly downgrading firmware versions is the last thing I want to do.
The other thing is that I need to invest enough time to try other methods that are not officially provided by the meta, such as downgrading. I need to understand the process and know what risks I have to take. Maybe my problems will get worse. I have not looked into the information including these risks yet.
I know that I can try something other than downgrading from the SideQuest app, and it may be a very easy solution to the problem. If the cause I'm thinking of is correct, all I have to do is make a few changes to the function. So, I'm waiting for the meta to fix this problem.
However...most software bugs have the problem that they are only easy to solve if you can actually 'reproduce' the problem. If the problem cannot be reproduced in a context where developers can check the code, solving the problem becomes difficult. I hope not.

Meta Quest Support
Meta Quest Support

Hey @BMO382 and @lordnozgot! So the team wanted to relay two things. The first is we'll need an updated software version of y'alls headset ( The other thing is to submit a bug report for them to pull from. 

Please let me know of the software version whenever y'all can. Thank you!

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

ok...I guess I have a lot of text. Let me write them down in order.


I reported this issue and updated it twice until today. One was about 18MB in size, and the other was about 9.9MB in size.


As you may already know, here's the version I had when I reported the issue:
=>Runtime version:


And the version after the update with 18MB capacity is as follows.
=>Runtime version:

And today, the 9.9MB post-update version is as follows:
=>Runtime version:

In conclusion, it is still not resolved. I am constantly having the same problem. Today, while testing, I saved a few screenshots.


You probably know this screen. This is how I scan my space and save my furniture. I scanned the living room of my house and saved the sofa, which I had never scanned before while using the Quest 3. As you can see in the screenshot, it looks very good.


But, look. Even though my controller is very close to the sofa, the area of the sofa is not displayed on the screen. As I said before, the area I apply to the bottom works fine. This screen is the one running Virtual Desktop, and before the problem occurred, I could see the walls and furniture I scanned normally on this screen.

Let's try another test. I changed the area of my space to a fixed range and loaded the virtual environment of Quest 3 instead of Virtual Desktop. (This refers to the space you enter by touching Quest 3's head twice) And here, I can't load the sofa I scanned. It's not just furniture. The same goes for walls.


I usually play with a fixed range. It was easier to move around in a circle. Either way, it doesn't solve my problem.

I told you about the bug report, but I can't send it. The reason is simple. Because entering my problem using the trigger on the Quest 3 controller is extremely painful. Look at how much text this is. It is possible for me to attach photos and send test details here and now because I have a keyboard and mouse in a PC environment.

Anyway, I submitted an issue and was surprised and excited to see that an update was actually happening. The update won't exclusively solve my problem, but it's definitely better than no update at all.
Additionally, I've already tested turning the option to not display walls, furniture, or areas of my space that I scanned on and off several times in developer mode. Actually that mod works. It just turned a circle near my foot on and off. The problem hasn't been resolved.

I hope my report will help you solve your problem. I hope my problem gets resolved soon and I can add VR into my daily life again.

=>Runtime version:
I have the same problems as described by BMO382

Meta Quest Support
Meta Quest Support

Thank you y'all for providing me all of this! Can I also get confirmation that the bug report was submitted? The team needs this as it helps them look into the issue for them to try to replicate it.

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

Support case #06921978 has been created for you.


Hey @lordnozgot! Glad to see you made a support case, this should bring more exposure to the issue. However, can you confirm if you submitted a bug report?

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.

This contact to support is the submission of an error report. I submitted a bug report and wanted to attach a video, but it's too heavy.

Hello. Have you solved this problem? Today another update arrived, but the problem remains. I tried everything that the support team advised, but it didn't help.

As of the last V64 PTC, and the release version of V64 (as corroborated by multiple other users when contacted), “Show Mixed Reality Objects” is missing from the Space Setup menu in Settings on Quest 3. The following is the feature appearing correctly in V63:


This option is missing in V64, and in VR applications, the furniture outlines defined in Space Setup do not appear. This is HORRIBLY dangerous for users relying on this feature to safely use their device, as they will no longer see any indication that their hands or head are close to these objects, possibly resulting in serious injury.

I cannot update as long as this remains broken, my headset will not be usable in my only available space. I have encouraged all impacted users I have contacted to report this as a bug. This should be addressed.


Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?