Showing results for 
Search instead for 
Did you mean: 

Quest 3 Walls or furniture saved as space settings are not visible on screen after PTC V64

I have a Quest 3 and this is my first PTC update. However, I am having a problem with 'Space Settings'. I never had this problem before the PTC update.
Scanning my room, adding furniture, and adding walls or windows works fine. It was also possible to name rooms, edit rooms, and modify furniture as normal.
However, the space and furniture set up this way are not displayed on my screen in the virtual environment. Previously, when I brought the controller or Quest 3 near a wall or furniture I had set up, it would appear blue, but now nothing is visible.
The problem is that the spatial data saved in the spatial settings remains. I repeatedly deleted and recreated this space, but it did not solve the problem of not being able to see it in the virtual environment.
Borders are saved normally and are visible. The option to change the color also works fine. However, only the border is visible, and no walls or furniture are still visible.
This feature was one of the most important safety nets to avoid getting hurt in the VR environment of my room. As I moved, I could see the blue output of furniture or walls and reset the distance or move in a direction that wouldn't hurt me.
I tried everything I could to solve this problem. I repeated clearing the space and rescanning dozens of times, resetting once through the phone app, and once through the device's power options, but it did not solve the problem. I still can't see any furniture or walls and this doesn't change whether I'm in a virtual or passthrough environment. The space is saved, the furniture and wall settings are also saved, but I don't know why they don't show up on my screen.

My request for help was written through a translator, so the terminology may be slightly different and I need your understanding. I hope the meaning was conveyed correctly, and I hope this problem is fixed quickly. Now that I can't see the walls and furniture, I'm scared to swing my arms or move my body while wearing VR. This is especially true because I have been bumped into and injured a lot even in environments where walls and furniture are visible.
109 REPLIES 109

Honored Guest

Today i try the meta depth api, (to display obstacles in the playing zone) it's working but it's visualy not so great...


My Quest 3 has now been forced onto V64 (due to the headset updating itself even if you turn updates off, if an update gets old enough), and as a result my headset I paid $500 for is now a paperweight.

Please please PLEASE fix this soon, I am extremely disappointed it has already taken this long and it's going to weigh heavily into future headset purchase decisions I make. It feels really bad not being able to use what I paid more than half a grand for after tax, after less than a year of owning it, for no fault of my own, and with no way to prevent it...

I think it’s more than obvious by now that Meta is either grossly incompetent or more likely, they just don't care. Never have and never will. **bleep** Zuck, I'll never buy another Meta product!

My room has 2 beds and a closet, I configured the physical space and during the configuration it works, but during games or normal use, my headset does not show the outlines of the furniture, just the normal limit.

Same issue for me. Since V64 (Currently on V65) my space setup and guardian setup work as intended. Once i enter VR i get warnings about my walls when controllers or headset get close, as it should be, but my furniture doesnt appear in vr. Walls get the blue warnings, but the furniture gives no warning.


Still not working on V65... And still no word on even a timeline?

Yes...unfortunately there is no good news. No one who has reported their experience with this issue has yet reported that it has been resolved. I don't even know if Meta is really aware of this problem. Since this problem still affects only a small number of people, they may think that people who suffer from this problem are just 'unlucky'.


Hey there, @Fussion1, and thank you for bringing to our attention you're experiencing the same issue regarding your mixed reality. As our team is currently still looking into this concern further, we are dedicated to getting to the bottom of this, and do ask that a Bug Report is submitted to allow our engineers to continue investigating. Once more details can be provided, we will make sure our team reaches out here on this thread to keep everyone up-to-date! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

At the moment, my headset has been updated to V66 and the problem has not been solved. I've been submitting my bug reports for a long time, but I don't see that it would help in any way. I was only offered to send my headset back under warranty, but you advised me not to do this and to wait for updates that would fix it. It’s been 2-3 months since the problem appeared, and you still haven’t been able to do anything. The impression is growing stronger that either Meta doesn’t care about this, or you are afraid to tell the truth, that you are not able to figure out and fix the device you created. But this is a problem of the physical safety of users, what could be more important?!?!
And you know if something is difficult to report about an error that doesn’t exist! Because the headset does not show any errors, a number of functions have simply disappeared! It seems that my Quest 3 started to think that it is Quest 2 and now it works like that.
Question: why did I change my Quest 2 to Quest 3 and pay Meta 560 euros??

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?