Showing results for 
Search instead for 
Did you mean: 

Quest 3 Walls or furniture saved as space settings are not visible on screen after PTC V64

I have a Quest 3 and this is my first PTC update. However, I am having a problem with 'Space Settings'. I never had this problem before the PTC update.
Scanning my room, adding furniture, and adding walls or windows works fine. It was also possible to name rooms, edit rooms, and modify furniture as normal.
However, the space and furniture set up this way are not displayed on my screen in the virtual environment. Previously, when I brought the controller or Quest 3 near a wall or furniture I had set up, it would appear blue, but now nothing is visible.
The problem is that the spatial data saved in the spatial settings remains. I repeatedly deleted and recreated this space, but it did not solve the problem of not being able to see it in the virtual environment.
Borders are saved normally and are visible. The option to change the color also works fine. However, only the border is visible, and no walls or furniture are still visible.
This feature was one of the most important safety nets to avoid getting hurt in the VR environment of my room. As I moved, I could see the blue output of furniture or walls and reset the distance or move in a direction that wouldn't hurt me.
I tried everything I could to solve this problem. I repeated clearing the space and rescanning dozens of times, resetting once through the phone app, and once through the device's power options, but it did not solve the problem. I still can't see any furniture or walls and this doesn't change whether I'm in a virtual or passthrough environment. The space is saved, the furniture and wall settings are also saved, but I don't know why they don't show up on my screen.

My request for help was written through a translator, so the terminology may be slightly different and I need your understanding. I hope the meaning was conveyed correctly, and I hope this problem is fixed quickly. Now that I can't see the walls and furniture, I'm scared to swing my arms or move my body while wearing VR. This is especially true because I have been bumped into and injured a lot even in environments where walls and furniture are visible.
109 REPLIES 109

Hello there, @Hirothefox! We appreciate bringing this to our attention along with the details. We understand your concern with the objects no longer being visible and want to ensure the safety for all users. If you should be using the Meta Quest PTC we would recommend removing this then attempting. For the steps to remove the PTC along with other information, it can be found here.  Should it still be encountered outside of the PTC please submit a bug report. Feel free to reach out to us again if you come across any other questions, and we will be happy to help! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I am not on the PTC, as the PTC had this problem, prompting me to leave it back to V63. V64 release version still has this problem as reported by several users.

Should clear up any confusion.

My concern is that I will no longer be able to use my headset safely if I update it to V64, as this issue prevents me from even playing seated in my space without risking damage to property or myself, and downgrading is not possible. I use the Show Mixed Reality Objects feature to clearly display furniture within VR, and that is no longer possible in V64.

This issue has been raised by multiple other users both within this forum and other places like Reddit.

The issue appeared at some time during the PTC and is still not resolved.

Hey there! We appreciate the quick follow up. Thank you for reaching out, bringing this to our attention, and providing us with details on this matter. We understand how this can disrupt an amazing VR experience as well as be a safety concern, as we aim for all our users to be able to navigate through their devices as smoothly as possible, and we will continue to look into this further. For now, please submit a bug report. Please contact us back if you should need assistance with anything else

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

That's... You realize you are telling me to update to the version of the OS that would prevent me from using my headset safely, just to do that, right?

I am working with other developers currently on V64 to send as many bug reports for this issue as possible, but I am unable to do so appropriately from my own headset, because it is not on V64, because in V64 this important safety feature is broken, and I want to use my headset. 


Since I can see no further action happening on this issue in this thread, I have made my own as well. It would help if you respond there too.


I performed the update, and the size was about 9.8MB. However, nothing has changed. The problem still persists.

Thank you for reaching out to us again. We understand this can cause some concerns about safety. This matter has been brought to the attention of our engineering team, and they are aware of this and are currently looking into it. More information and updates will be given in this thread, so please follow it there! If you have any more questions, don't hesitate to reach out to us again, and we will be happy to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I checked the comments you left.
I thought this was a problem that only happens on PTC. Actually, because I moved on to V64 first through PTC. But it's very unfortunate that even the official release version has this problem.
The cancellation of the PTC presented by Meta didn't mean much to me. The explanation is that if I turn off activation of the PTC channel, I'll start the downgrade, but my Quest 3 device hasn't changed. I haven't proceeded with any updates, nor have I downgraded. Even though I did initialization of the device (which refers to both what you can do with the Android app and what you can do by manipulating the device's power + volume button) with the activation of the PTC channel off, I didn't get back to V63. It was all when the V64 was still on the PTC.
I can see that updates are being done periodically. I first registered on the PTC channel with this V64, and I don't know if it's limited to PTC, but I felt that there were frequent updates. This is not a bad thing, because it's not left unattended.
However, I'm not sure if the update is actually an update to fix this issue. This happened, and it was already three weeks ago that I reported. In the meantime, I've had four updates, and there was nothing I could do but answer the answers asking me to give you the version each time. To be honest, I also feel like this is not a major bug, it's a minor bug, and it's a symptom that only happens in a small number of users, so I'm sure it's neglected. Think about it. Safety is critical, and this bug is directly related to safety. How long on earth should I wait?
I also find it hard to believe that the issue was officially released without being able to fix it in PTC. If it's hard to fix, I think we should give users the option to downgrade the version. It automatically progresses updates every time, users can't select, and won't tell them what updates are available. Is it that hard to attach update logs to each update? Still, I force updates, and the bugs that come from there are just because I wasn't lucky? If so, let's say it was intended. If so, why can't I check the prompt for this 'intended' and Meta doesn't correct me saying 'bug'?
Yes, it's true that I'm angry. I've been waiting a long time. How much longer do I have to wait? Should I wait until V65? By that point, my quest will be in the warehouse and will forever be forgotten by me.
Every time I use quests, the space I scanned collapses, it's distorted, the furniture is twisted, the tracking of the controller and the device is broken, the device is not properly positioned... I'm experiencing all sorts of problems. In particular, the space I scanned collapsing is a disaster itself. I scan the room once a day, set up furniture... is this normal?
And yet, I've used most of the problems with 'understanding' of them. It's not because I'm stupid, it's because I believe it will improve for the better. In fact, the changes and improvements to the V64 are very encouraging on the surface. The resolution of the past-through is improved, and more and more features are being added.
I'm kind of tired now. When I check the update, the expectation that the issue is fixed is fading. What can I do other than leave my VR device unattended?


It is definitely still not resolved, I am working with community devs to put through as many bug reports for it as possible. Here's hoping for a speedy fix

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?