Showing results for 
Search instead for 
Did you mean: 

Quest 3 (and my old Quest 2) only recognize USB 2 rather than USB 3


My old Quest 2 had the same problem but I just decided to live with it until I upgraded, but my Quest 3 now has the identical problem. I've read and tried fixes and workarounds I've seen on many posts (including some in this forum dating back to 2020). Quest 2 and 3 always negotiate a USB 2 connection rather than USB 3. I've tried multiple USB cables, C to C, A to C, long cables, short cables. All cables tested can provide USB 3 to other devices on this computer. On a previous machine (intel 12th gen with an ASUS Z690-P D4 motherboard) which also had USB 3 both the Quest 2 and the Quest 3 can negotiate a USB 3 connection using any of the cables I'm testing with.

Fresh install of Windows 11 Pro.
All headsets are up to date.
Chipset drivers up to date (and have been re-installed)
All USB controller drivers up to date (and have been re-installed) - most recent driver released on March 14th 2024.
Fresh install of windows.
Both USB C 3.2 GEN2 ports tested.
Each USB A 3.2 GEN1 and GEN2 ports tested.
GPU driver updated (and re-installed using DDU to clean up first).
Power management for all USB devices disabled.
Oculus software has been re-installed.

CPU: 7950X3D
GPU: 7900XTX
Motherboard: ASRock Steel Legend X670E

Honestly if I can't find a resolution to this I'm just going to return the headset. I like the device itself so far and would like to keep it but this issue is 100% a deal breaker, especially after dealing with the same issue on the last Quest.


Honored Guest

I have a similar issue. I've been digging the web since 2 days trying to find a correlation to this problem. 

I've been using my Quest 3 since January using cable Link on my gaming Lenovo Legion 5 laptop. Everything works fine without troubleshooting ever. Now I wanted more power and decided to build a desktop. Fresh install of Windows 10 or 11, it doesn't matter, my Quest 3 negotiate only at USB2. If I go back to my Lenovo Legion 5, same headset and same Link cable, everything is fine, getting 2.5Gbps on cable test. Try again the desktop and will get USB2 connection only. If I can't get Quest 3 working on this build, I may have to find another VR headset.

I'm starting to think that the USB from the chipset X670E presents an issue with Quest 3, Here is my build :

MSI MAG Tomahawk X670E WIFI Mobo
Ryzen 9 7900X3D
64GB DDR5-6000mhz
Gigabyte 4080Super 16GB

Community Manager
Community Manager

Hey @SomeDuncanGuy! Thanks for reaching out about this, as we would love to help. We would also like to thank you for providing us with detailed information regarding the steps you have already taken to resolve your issue. We would like for you to try and reseat your USB cable from your PC; this could be what's causing your issue. We also would like for you to attempt to reboot your PC as well and see if this helped at all. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

All the different suggestions offered on different forums but most important from the Meta Support page :

Also to note that the same Link cable works fine on my Lenovo Legion 5 laptop :
Ryzen 7 7745HX
32GB DDR5 5200
Notebook 4070 8GB DDR6

Nothing to do with my desktop build, it will only negotiate at USB2.

Community Manager
Community Manager

Thank you @SomeDuncanGuy, for the swift response and further clarification. We appreciate you and your patience as we investigate this matter deeper. Does the Quest 3 connect with the USB2 on either your Lenovo Legion or your recent PC build? Is the USB3 cable the one that came with the Quest 3 headset?  We're looking forward to speaking with you soon. Have a legendary rest of your day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks for replying. Not only have I tried re-plugging the cable in (both on the PC and the headset) but I've tried multiple cables (including the ones that come with the devices). I stated in my troubleshooting steps that I've actually re-installed windows in an attempt to resolve this as well as re-installing drivers, so I can promise that a great many system restarts have been done while troubleshooting this issue.

I replied to the comment from you directed at me above, the the comment regarding the Lenovo was from another user with a similar issue: @Yudge19 

Yeah it's rough. I assume it's a compatibility issue with the extensible USB controllers but I can't understand why this is such a longstanding issue with the Meta hardware. They are the only devices I own that don't negotiate a USB 3 connection.

Same thing for me, only the Quest 3 will not negotiate USB3.

Hey @Yudge19! We know that having these connection issues can be a real drag, and we'd love to help investigate this. So we can better understand exactly what you're going through, can you let us know what troubleshooting steps you've already tried? Also, has the device ever worked plugged into your usb 3.0 port? We look forward to your reply!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?