cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 3 doesn't find my WiFi 6E network

TheodonKhel
Expert Protege

I just setup brand new Quest 3 and it doesn't detect my WiFi 6E network (router ASUS AXE-11000). 2,4GHz and 5GHz is detected. Quest Pro that I have used to have the same problem but it would eventually detect my WiFi 6E network after several reboots or/and waiting few minutes. Latest v57 fixed it for Quest Pro and from then on it would detect WiFi 6E network immediately or after 10-15 seconds. 

Unfortunately it's not the case for Quest 3. I tried a few different channels and restarted many times. Tired to add SSID manually. Nothing works. I can't really use WiFi 5GHz to play PCVR because I have several 5Ghz networks around me that cause interference so 6GHz is the only way.

Edit: After many more attempts of chaning channels and different settings on the router, restarts of the router and the headset I still can't get it to find it. It did show up for a brief while but when attempted to connect it says "can't connect, try again later" and disappears from the list. 

This is the exact same problem that happened on Quest Pro just more pronounced. Meta you need to address this issue. I have too many 5GHz networks around me so 6GHz WiFi is my only choice.

80 REPLIES 80

Hey @RazMil77! We know how important it is for you to be able to connect your new device, on the fastest possible network. We also understand how dealing with connection issues can take away from your VR experience. A few questions we have for you:

  • What software version is on your Meta Quest 3?
  • Can you connect to 2.4 or 5 Ghz with this router?

A few troubleshooting steps:

  • Can you try and disable 2.4 or 5 Ghz?
  • Can you try manually setting different control channels on your router's Wi-Fi 6 range settings?

We look forward to hearing back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there! We wanted to follow up with you and see if you had been able to perform the steps we provided, or if you still needed assistance with your issue. Please reach back out to us and let us know if we need to look into this issue further with you or if the issue is resolved.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

This response is so wrong. You were happy that a customer of yours returned a product because they were not happy with how it functioned and went back to something that was working. This is why i hate meta right now. 

I can step in with the same problem. My Quest can connect to 2.4 or 5GHz networks. It can't detect 6GHz network. I've set manually 6GHz to channel 37, but it did not help. I use Ubiquiti's U6 Enterprise Access Point. My WiFi password is WPA3 Personal.

To make sure it's not a precedence issue in the code, did you try to have a distinct SSID per network?

Yes, I have 3 networks one for 2.4GHz, one for 5GHz and one for 6GHz. When I add 5GHz capability with band steering to the 6GHz network it shows on my Q3 but info tab shows 5GHz and WiFi6. My region is Poland tho. Maybe that's the problem?

Hello @jAANUSZEK0700! We would love to go ahead and assist you with getting your Quest 3 to connect to your network. We would love for you to be able to connect your Quest 3 to your network seamlessly. Your region may be the cause; however, let's go ahead and try some basic troubleshooting to check and see if that will help. 

 

You can try to connect it via phone by following the steps below. 

To connect the Quest to a different Wi-Fi network from the phone:

  1. Turn on your Meta Quest and open the Meta Quest app on the phone.
  2. Tap Settings from the bottom menu.
  3. Tap the headset currently in use.
  4. Tap Wi-Fi.
  5. Tap the new Wi-Fi network and enter the password, if prompted.

If those steps do not work, please try the following troubleshooting steps:

Troubleshooting frequent Wi-Fi disconnects

  1. Reboot the headset.
  2. Remove any unsupported third-party accessories that may affect communication (such as headset covers, etc.).
  3. Try connecting to a different network.
  4. Perform a factory reset.

If these steps do not correct the issue, please let us know so we can provide further assistance! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

My phone is connected to 6GHz network, but Meta app can't see it. When trying to add network manually from the phone I can't see WPA3 Personal in the list of password security options. Which hints that Quest 3 does not support any WPA3 security protocol. But 5GHz on WPA3 works ok.

Hello again, if the 5GHz seems to be working ok we would go ahead and suggest sticking with it. The region might be the main factor, other options are not working. Feel free to reach out to us with any other questions or concerns.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I bought 6GHz router exactly for this reason. The Meta page says Quest 3 supports it. And now i have to use the busy bandwidth.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?