Showing results for 
Search instead for 
Did you mean: 

Quest 3 - second (non admin) user boundary not persistent/not saved - can anyone try to replicate?


I set up two accounts on Quest 3, and it does seem like additional user boundary is not being remembered - I switch to 2nd user, asks for boundary, I create one, swtich back and forth and bam, boundary is gone.


Did that happen to anyone else? Do you guys (and gals) have any ideas on how to troubleshoot that?
Tried readding multiple times, lightning conditions are good, nothing changed in the environment.



Yes. This is actually not new. I have seen this on both my Quest 2 and Quest Pro, but not always. I reported this before, but it still hasn't been fixed.


Really? So they don't care THAT much? This makes experience annoying a lot - as we have three users in the household, and for sure I am not buying 2 more headsets! 😉

Can you try to replicate this issue again? I'm mailing the support but for now it seems like they will ask to send the device back, while it feels to me more like a software problem - as the general boundary scanning works just fine.
The problem is only with non-admin account boundary not being persistently saved, which I suspect could boil down to permission/privileges issue on local filesystem/database...

Steps I did after a factory reset - but feel free to replicate without it, if you'd be so kind!

1. factory reset device
2. setup main user (admin) account again
3. set up admin user boundary
4. add second user
5. set up second user boundary
6. relog to admin user - boundary gone
7. set up admin user boundary again
8. relog to second user - boundary gone
9. set up a second user boundary again
10. relog to admin user - boundary present
11. relog second user - boundary gone
12. back to step 9 loop - tested multiple times

Yes, it is exactly like that on my Quest 3. Don't send the headset back because the new one will have the same problem. How do I know? Because my Quest Pro is like that, and my Quest 2. I have been dealing with this pain for a long time.

Hello there, @Geezik and @Geezik! We definitely don't want your secondary accounts to continue forgetting your headset's boundaries, as we can tell how dismaying it must be to have to re-set it up every gaming session! With this in mind, we ask that you submit a bug report to bring this issue to the attention of our engineers. Please use these steps to do so from your headsets:

  1. Press on your right Touch controller to pull up your universal menu.
  2. Hover over the clock on the left side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel.
  3. Select Report problem.
  4. Follow the instructions to submit your bug report.
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi @MetaQuestSupport !
I am already mailing with support, but I'm afraid the usual "runbooks" 1st level of customer support is working along do not have (so typical in usual IT support models) proper escalation paths - they are going toward me sending the headset back, instead of escalating the case to higher support level. As an IT engineer and programmer myself, if I'd have to bet, I would go with software/privileges issue, not a hardware one.

As a community manager in this community is there an option for you to somehow connect my bug report, with the support case and/or user reports on the forum? It really looks like wider, replicable issue.

Even better - comparing with reports from different sources/threads I stumbled upon some bloke having an issue of not saving previously used boundary when switching to new one/stationary. Meta support replied in there that if they're too close, overlap even, then might overwrite.

That would suggest few possible scenarios:
1. Permission issues - in mu case admin boundary is persistent, second non-admin user boundary is deleted on every relog/restart. I would suspect permission issue - non admin user not being able to data structure admin is being able to write to
2. wrong implementation of whole boundary comparison on save (it does have to happen if they're overwritten by design when similar). 

Hello there! We definitely understand where you're coming from here and we'd like to do our best to help! With that said, if you have already been in touch with our support and they're currently looking into replacement options for you, please be aware that these are the next best steps we can recommend from this point, beyond getting a bug report directly to our engineer team using these steps. Submitting a bug report with those specific steps will keep our engineers informed on this specific issue so they can better address it. We really suggest sharing all of those mentioned details and your researched findings with with them for best results. Thank you for your patience and understanding while our team investigates this issue for the benefit of all users! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


Yep. Seeing this. Shared apps are also disappearing from the guest accounts often. Usually when they've tried to record a video or take a screenshot. Having to remove the guest account and re-add it to get them back.

@Legiless Would you be so kind and open a separate bug for app disappearance? I already opened one for second account boundaries. Unless it's better to open more - to let support know that the issue is widespread indeed, and not an isolated one.

Opening the bug from quest itself is a bit inconvenient, as typing in vr is suboptimal - I installed whatsapp and pasted/copied whole bug report from pc (just a hint)

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?