cancel
Showing results for 
Search instead for 
Did you mean: 

Quest Link / Air Link session closed immediately after launching

mrevilboj
Explorer

Beeen using my quest 2 for a couple of months now, and its stopped being able to connect via either quest link or air link. As soon as I launch either, it says session disconnected.

It is able to be detected is the meta quest link software, and a USB test works fine.  Using a 3rd party link cable but that hasn't been a problem up until now.

mrevilboj_0-1719134076354.png

Have tried uninstalling and reinstalling the meta quest link software, and also factory resetting the quest 2, neither of which worked. Have submitted a couple of bug reports as well. 

PC specd:

i5-13400, 2500 Mhz

32.0 GB RAM

NVIDIA GeForce RTX 3060 Ti

 

 

8 REPLIES 8

Automatcjt
Honored Guest

Having the same problem with quest 3.

MetaQuestSupport
Community Manager
Community Manager

Hey there @mrevilboj! Looks like you're having some issues with your Quest/Air link. We're here to help you out and get you back up and running, so let's work on this together! Thanks for sharing the troubleshooting steps you've already taken and providing your PC specs. We just have a few more questions to ask to gather more information.

 

  • Has Air Link ever successfully connected to this PC in the past?
  • Are there any VPNs, antivirus, or proxy running in the background that may be affecting your connection with the Meta servers? if so, disable any VPNs or antivirus that could be interfering with the headset's connection.
  • Make sure your GPU drivers are up to date.
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

  • Air link has successfully connected in the past
  • Only basic windows defender, no other antivirus (oculus software is whitelisted), no VPNs
  • Tried updating GPU drivers as well and that didn't help

Thanks for getting back to us with the details. Below are some troubleshooting steps that can help with the link issue that we would want to go through next. 

Check Connectivity:

  1. Open the Meta Quest PC app on your computer.
  2. Turn on your Quest headset.
  3. Plug your USB 3 cable into a USB 3 port on your PC, and then plug the other end into your headset.
  4. A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
  5. When prompted to Enable Meta Quest Link, select Enable to begin remote rendering using Meta Quest Link.

Ensure Air Link is disabled in Settings on the headset:

  1. Put on your headset, then press / on your right Touch controller to pull up your universal menu.
  2. Hover over the clock on the left side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel.
  3. Select Quest Link.
  4. Select the toggle next to Quest Link to enable access to Quest Link. It should now also appear in the quick settings menu.
  5. Select the toggle next to Air Link to turn this feature off.

To help keep your Wi-Fi connection secure, only share your Wi-Fi password with trusted devices and avoid using Air Link on a shared or untrusted Wi-Fi network.

 

Repair the Oculus PC Application:

  1. Go to www.oculus.com/setup and click Download Oculus software.
  2. Select Repair.
  3. If Windows asks you if you’re sure you want to open this file, click Yes.
  4. If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.
  5. If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
    Please remember to re-enable your antivirus software once you've completed the repair.
  6. Allow the repair process to run, download and install.
  7. Launch the Oculus app.

USB power settings:

  1. Open Device Manager.
  2. Locate your USB ports - Expand the universal serial bus controller section at the bottom of the list. Look for the "USB 3.0/3.1/3.10 eXtensible" items.
  3. Right click and select Properties.
  4. Navigate to Power Management.
  5. Ensure that the options to save power are deselected.

Selective Suspending:

  1. Right-click Start
  2. Click Power Options
  3. Click Additional Power Settings
  4. Click Change plan settings
  5. Click Change Advanced Power Settings
  6. Find USB Settings
  7. Make sure that Selective Suspend Setting is set to Disabled, and not Enabled.

Please let us know if you still encounter any issues after following these steps. Have a great day.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

mrevilboj
Explorer

When I try to complete this step:

"A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in."

I don't receive an option to deny the connection. The notification says:

"USB Detected. Click this notification to allow connected device to access files"

We really appreciate you trying that out, @mrevilboj! Since you're receiving that error message when checking your connectivity, we did want to be sure to touch on the specific link cable you're using to connect, as you mentioned earlier. It's essential that we let you know at this time, we recommend using the Meta Quest Link cable or the Anker cable for the best PCVR connection. We cannot guarantee a consistent and stable connection with any third-party cables, as our engineers have not yet been able to test any, save for the ones we've just mentioned. With this in mind, let's focus on getting your Air Link back up and running! Please confirm whether your current play environment meets our recommended best practices for a successful Air Link connection and we can continue from there: 
 

  • Have the PC connected to Router/Access Point via Ethernet cable and not Wi-Fi
  • Headset should be connected to Wi-Fi via 5GHz band (AC or AX)
  • Router in the same room as the headset or in line-of-sight, and at least 1m (3.3ft) off the ground
  • Be sure to use a non-mesh network configuration
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Confirming I tried this, and am getting the same error. With air link on I can see my PC in my quest 2, and it says it meets requirements, but still disconnects immediately upon trying to connect to it.

Given all the troubleshooting tried in this case, we do want to bring up a thread we have on the forums here, as it does have a few workarounds for some ongoing Air Link connection issues that our engineers are aware of. We hope some of these may help as it seems like you may be running into this or a similar issue. That said we can look into some other options for you if you continue to have issues outside of what is mentioned in that thread, but we would need you to reach out over a private message to look into that. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

 

We hope the thread does provide some help and more information, but if you need further help, we will be here and happy to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?