cancel
Showing results for 
Search instead for 
Did you mean: 

Quest Link borked, please help

Scruffy.Nerd
Level 2

Having a problem, hope someone here can help.

 

Here's my setup, for context;

5900X, 32GB DDR4, RTX3090 24GB

Quest 2, 64GB version (from before the meta move) + 16ft USB 3.0 cable (tests show 2.5-3 Gbps)

 

So i went to use my quest 2, enable quest link, select my pc, and get 3 dots loading menu. then it fails back to home screen after a bit. I've had this problem before, several times. the 'solution' seems to be to uninstall oculus software and reinstall it, which is not really feasible for metered internet, since there's no offline installer and and it downloads 6GB each time.

 

It's a weird bug, but i'm fairly certain its software and not hardware, since last time i 'fixed' it i played steamvr games for 4+ hours just fine. something something, i'm done playing, turn headset off, next day i try to connect with quest link same problem.

 

oculus software reports in devices, quest 2 active and connected, in the headset when i select quest link my pc shows up as Rift, click connect. 3 dots loading screen for 1+ minute before fails back to oculus home area. restart, same result, power off and one, same result.

 

With new update, i used to get 2 pop ups each time i started the quest, allow access to files, which i selected deny and don't ask again, and connect quest link which does the same as the above and also doens't work.

 

what's going on? How do i fix this? I cant just be downloading 6GB everytime i want to play vr, so unless someone can point me at a method to cache the download reinstalling the software each time isn't a fix.

1 ACCEPTED SOLUTION

Accepted Solutions

Scruffy.Nerd
Level 2
UPDATE: Seem to have found the fix.
C:\Program Files\Oculus\Support\oculus-drivers\oculus-drivers.exe
then restart when prompted, now quest link works as it should

View solution in original post

1 REPLY 1

Scruffy.Nerd
Level 2
UPDATE: Seem to have found the fix.
C:\Program Files\Oculus\Support\oculus-drivers\oculus-drivers.exe
then restart when prompted, now quest link works as it should