Showing results for 
Search instead for 
Did you mean: 

Quest Link keep crashing a few seconds after launch on Quest 3

Honored Guest

I got a $30 Syntech link cable off of Amazon. I plugged it into my high end PC, plugged it into my Quest 3, and it worked for the first 3 days. I was able to play SteamVR games, which was what I intended on using it for. Suddenly, it stopped working and started crashing randomly. My screen would freeze once in the Link screen after about 5 seconds, then on my PC it would give me a notification from the Quest app that my headset randomly disconnected, and it told me to plug it back in. The cable was plugged in, so I tried to unplug the cable and re-plug it both my PC and my quest, and sometimes it wouldn't even start up. Nothing works.

I have tried restarting my Headset, I've restarted my PC, I still have a bunch of storage left on both devices and I can't seem to find the problem. I'm not sure if it's the cables fault or my hardware's, but I'm starting to get upset knowing the fact that I wasted so much money on these devices for them to not work. I don't have PTC enabled, but I do have developer mode on.


I encountered the same problem, and updating my graphics card drivers on my PC resolved it. I have an Nvidia 2080S card. Additionally, I disabled the experimental option, following some troubleshooting advice I found on Google. This solution worked for me after updating all my software, including a needed update for my headset. Previously, the screen would black out every 10 minutes, but now it's resolved. I hope this solution works for you too!

Community Manager
Community Manager

Hi @TyceIsNice. We understand you are having issues with crashing. We know how this can get in the way of fully enjoying your VR experience, not to worry we would love to assist further and see what exactly could be causing this. How were things running before you started using the new cable? If you don't mind kind of updating us about things, we can definitely get things rolling. We appreciate you trying some troubleshooting on your own, and we would like to know if you followed any steps that @Megolito has offered. Please let us know at your earliest convenience so we can proceed accordingly. Thank you.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

Hello again, @TyceIsNice. We just wanted to stop by and see if those link issues were still happening. If you have resolved the issue, share the news!! If you are still needing assistance, please let us know. We eagerly await your response.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I already update my drivers it still don’t work

Hello there, @PKT8389! Thank you for bringing this to our attention. We know that having Meta Quest Link issues while trying to enjoy VR gaming can disrupt amazing gameplay, so we are interested in getting to the root of this issue and getting you back to a smooth VR experience. In order for us to get a better understanding, could you please answer the following questions listed below? 


  • What error messages, if any, are you seeing?
      - If there are no errors, what is the exact behavior have you experienced?
  • Has the Quest link ever worked before on your device?
  • When did you first notice this behavior?
  • What else changed when you first noticed the behavior?
       - Did any of your devices (phone, headset, or PC) receive any updates?
  • What troubleshooting steps have you already tried?
      - If applicable and available, have you tried on another device?
      - Is your PC compatible? Please click here to ensure you meet the minimum requirements to use Meta Quest Link.
  • Does the headset work when it is not connected to a PC?
      - Test basic functionality (navigate menus, launch, and use an app).
  • Are you connecting your USB cable to a USB 3 port?
  • What type of cable are you using? Try another compatible cable, if possible. For example:
      - Included USB Charging Cable
      - Meta Quest Link Cable
      - 3rd-party retail cable
  • Is an adapter or cable extender being used? If possible, remove any adapters from the headset.
  • How many other USB devices do you have connected to your PC?
      - Test with the bare minimum of USB devices connected to the PC (just a keyboard and mouse).
      - Try the cable with other USB 3 ports.

Once we can get this answered, we can know what course of action is best for us to take next. We look forward to hearing back from you soon! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

There’s No Error Message - It Just Freezes so nothing moves and it’s just a screen but black all around it and then sometimes it’s just u need to re plug ur cable back in. I know it’s not the cable since I tried it with another one and even if I use air link it still does it and it started to happen like a few weeks ago before that I used to play without no crashes no problems. My PC does meet the requirements and I have repaired the Oculus PC App and reinstalled windows. I am using a usb 3.0 third party retail cable. I don’t plug it into the back of the pc because the usb bends down so I plug it at the front and I only have a keyboard,mouse and wifi adapter connected 

Thank you for confirming all that information, @PKT8389. At this point we would recommend a clean reinstallation via the steps provided below:


  1. Disconnect the Link cable from the computer
  2. Disconnect your computer from the internet
  3. Backup any necessary content. You can find steps on how to do so by clicking here.
  4. Reboot into Safe Mode. You can find steps on how to do so by clicking here.
  5. Uninstall the Oculus PC app using the Control Panel. You can find steps on how to do so by clicking here.
  6. Delete all Oculus folders from the following folder:C:\Program Files
  7. Remove any Oculus folders from the following locations:
    1. C:\Users\YourUserProfile\AppData
    2. C:\Users\YourUserProfile\AppData\Local
    3. C:\Users\YourUserProfile\AppData\LocalLow
    4. C:\Users\YourUserProfile\AppData\Roaming
    5. C:\OculusSetup-DownloadCache
  8. Restart your computer in normal mode
  9. Reconnect your computer to the internet
  10. Install the Oculus PC app again using the setup tool from our website here
  11. Reconnect the Link cable and re-test the headset
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi again! We're following up to make sure you got our last message. Please let us know how the clean install went, and we'll be happy to gather the best next steps!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?