Showing results for 
Search instead for 
Did you mean: 

Quest Link stuck on 3 dots then it closes

Honored Guest

when i start quest link it is stuck on 3 dots then it closes after 1-8 seconds 

when i tried going with airlink it worked normally 

but when i try with quest link it doesnt work at all 

i tried everything and it still doesnt work



Honored Guest

also i did factory reset my quest 2 and it still didnt work


That's because Meta doesn't give a **bleep** about PC support. I'm a Quest 3 day one purchaser and every time they have a major update, airlink is broken. I'm in the same boat as you are now and unfortunately been here several times. Meta just wants us to buy their games with crappy graphics that really only amount to glorified demos. They have abandoned PC support and that was a mistake. All this other **bleep** they are peddling is just novelty and won't last.

Hey there, @fekin44rfr! We're so glad to see you had sent us a PM and we're pretty eager to continue exploring this situation further with you! Please get back to us there when you have the time! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?