cancel
Showing results for 
Search instead for 
Did you mean: 

Quest Pro Controller Tracking Issues

MSPaintRose
Level 3

I think I have an issue with my controllers. I heard tracking can get lost with low lighting. I switched out my bulbs with LED daytime lightbulbs. I think it made tracking better, but it still happens too frequently. Wondering if this experience is expected or should I get an RMA on the controllers.

 

 

The Issue: My controller would become stuck to my body for several seconds and than it will catch up. It happens in Beat Saber to both controllers, my right controller more than my left. It also happens in SupernaturalVR, but event more frequently. About once every 1 minute or so. Sometimes I can make it 3 minutes.

 

It doesn't happen too often while just in the Quest launcher. The are the quest loads you in after bootup. Does not seem to happen while in Horizons or Immersed, but I don't move the controllers that much to notice that perhaps.

 

I also noticed that when the controller loses the connection, sometimes it does not come back until I power it back up and back on. When this happens, I notice the LED on the controller is blinking white, as if it is in pairing mode, However, to go into pairing mode requires both of my hands. I am unable to press that combination of buttons with just my thumb. This specific thing has happened to me just a few times though.

 

When I first did the setup for the Quest Pro, my right controller got stuck to my body and would not track properly even after powering off the controller, until I restarted the headset. Thankfully it has only done that once.

11 REPLIES 11

h.r.gargi
Level 7

I have similar experiences. Sometimes the get stuck or very often the position of the thumbs are wrong. Only restarting the controllers helps .... till the next time.

Facebook Power Admin
Facebook Community Partner
Founder of the Meta Quest VR Familie - The German Facebook Group for VR and Metaverse
https://www.facebook.com/groups/oculusvrgermany/

dracil
Level 4

Yep, been having the same issue. Every other VR session I have to deal with controllers losing tracking. I have tried turning on more lights, angled lights, brought more lights. Nothing seems to change. It just seems fairly random.

TomCgcmfc
Level 15

My Quest Pro controllers are working very well, better than my Q2 controllers and actually as good as my Index controllers with 2x 2.0 base stations.  Maybe go into your controller settings and set their freq to what ever your local power freq is (50 or 60Hz).  I've always found this work better than leaving it on default Auto.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, QPro w/Air Link, Vive Pro

Interesting, I'll give that a shot.

Yeah, unfortunately that didn’t work for me either. I’m in the states and have set it to 60.

dracil
Level 4

Out of curiosity, the people having issues, are you mostly using airlink, link, or native? I'm mostly on airlink, and I'm wondering if it could be something with the controller position information being dropped. The interesting thing is whenever this happens, the orientation of the controller keeps updating, but it's the position that gets stuck.

 

I've been using auto. I tried using link, didn't have problem (only tried one song though). Tried using 200 mbps, and had issues. Tried setting to 100mbps, didn't have issues. But it's all so sporadic that I'll have to keep trying to see if the changes have a consistent difference.


@dracil wrote:

Out of curiosity, the people having issues, are you mostly using airlink, link, or native? I'm mostly on airlink, and I'm wondering if it could be something with the controller position information being dropped. The interesting thing is whenever this happens, the orientation of the controller keeps updating, but it's the position that gets stuck.

 

I've been using auto. I tried using link, didn't have problem (only tried one song though). Tried using 200 mbps, and had issues. Tried setting to 100mbps, didn't have issues. But it's all so sporadic that I'll have to keep trying to see if the changes have a consistent difference.


I'm also mainly using my QP/rtx3090 for wireless PCVR with Air Link.  I'm using 200mbps Dynamic (not Fixed) bitrate set in the Rift home dashboard (using Zero in ODT).  All my games/sims have never worked better. 

 

I've also have used Link (with 300-500mbps bitrate) and of course, it does work a little better (eg. distant objects pop in earlier) but I still prefer the freedom of wireless.

 

Since Link seems fine with your QP then I suggest your problem is due to your Air Link Router/wifi setup.  Both the Q2 and QP are pretty picky about this and you need to follow the recommended setups.  Besides having your PC Ethernet cable connected to your 1gig or better Router, you need to make sure you're using a dedicated 5Ghz channel without other devices operation on this.  Also disable 2.4/5Ghz band steering and do not use Auto 5Ghz channel select.  It's worth trying different 5Ghz channels to find one that works best.  Apparently the QP wireless is having some issues with the higher freq DFS channels so maybe steer clear of those.  I'm using channel 36 and this seems to work best, plus lower freq's tend to have slightly better range.  Plus you need to be close to your Router's wifi, preferably in the same room.

 

You may also be getting some 5Ghz wifi interference.  This can be caused by a number of things like other 5Ghz wifi devices, BT devices, and even some wireless home phones and wireless security cameras.

 

Anyway, good luck sorting this out mate and cheers.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, QPro w/Air Link, Vive Pro

No I hadn’t done anything with pc connections except using horizon and immersed. Which doesn’t require moving the controllers a whole lot.

 

I will sign on to the thing about the controllers. Rotationally the controller works, but it’s just stuck on my body.


@MSPaintRose wrote:

No I hadn’t done anything with pc connections except using horizon and immersed. Which doesn’t require moving the controllers a whole lot.

 

I will sign on to the thing about the controllers. Rotationally the controller works, but it’s just stuck on my body.


Maybe you need to try the dreaded factory reset and go though setup again.  Also make sure your headset and controllers are fully charged before you do this and you have adequate room lighting.  If this does not fix you problem then contact meta support I guess.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, QPro w/Air Link, Vive Pro