Showing results for 
Search instead for 
Did you mean: 

Quest Pro Controller consistent tracking/connection drop issue

Honored Guest

I'm having a very strange, persistent issue with my Quest Pro controllers. I've tried just about everything (INCLUDING replacing them at my own expense!) but they continue to have this issue. I'll detail the issue, then what I've done to try and resolve it.


I'll be playing any game (either standalone, PCVR, single-player, or multi-player, doesn't matter) or even just using the UI/menus, and one, or both controllers will just freeze in position. Pressing buttons still appears to work. Sometimes (much less common) they'll fly off into outer space, and something that was common but hasn't happened in a while is both controllers resetting and going to 0,0,0 (basically the floor at my feet) for a bit.

When they're frozen in space, sometimes they'll come back on their own after 5 or so seconds, or sometimes I can get them to come back faster if I cover the cameras with my shirt, then they start to pivot around a point (as if their gyros suddenly started working or something), and if I uncover them, they come back and find themselves again. Usually only one controller will do this at a time, though sometimes it is both.


Originally, I was assuming that it must've been my controllers being old and "abused" over time, and actually found that (with that pair), that smacking them against my leg or the floor (or each other) would actually bring them "back" and start working again. So I decided to just replace them and bought another pair. Unfortunately, replacement did not work. And, I should add, I'm playing in a well-lit room as well.

Now, I live in a fairly dense residential building, so thought it could be EM noise on the 2.4GHz bands (which both WiFi and Bluetooth use), so I started poking around my WiFi APs and even my Zigbee configs to try and see if there was a particular channel that was having problems or if moving their channel could help prevent interference with the controllers. No luck.

Something that DID seem to maybe help (though feels less successful lately) is disconnecting the Quest Pro from Wifi (but leaving WiFi enabled, as the controllers seem to use WiFi to communicate, at least according to the warning if you try and turn off WiFi). I have also noticed that weekdays, during the traditional work day, seems to have less issues, and evenings have the most, which seems to suggest the interference hypothesis could be reasonable.


My (uneducated) guess here, would be a bandwidth issue sharing point-cloud data between the controllers and headset. The headset itself never loses tracking, only ever the controllers, and even when the controllers don't fully lose tracking, they sometimes will be "offset" a few inches before "popping" back into alignment. Given the room is well-lit with good visibility and a lot of distinct "landmarks" to track, this at least feels correct.

I've also tried contacting support, but it was pretty useless, every response came from someone else, and they just wanted to jump right to RMA, despite all the evidence suggesting that an RMA won't resolve this (I did already replace the controllers myself), but after mentioning that, they just wanted to RMA the whole headset.

Is there a way to pull up device debug logs? And see what errors might be coming up during the time that the issue occurs? I've been trying to look at my WiFi AP stats, and see if I can see a spike in retransmits or something around the same time (suggesting an increase in interference), but so far haven't seen anything that stands out more than expected background.

At this point, I'm at a loss, and am just trying to hold out for the Index 2 to be announced/launched, and would really love to have this be usable until then.



Hi @Dune_Cat 

I use the Quest Pro controllers with my Quest 3 and I must say the last update (v65) has caused the same experience for me too. The buttons work but the controllers are nowhere to be seen. Often they don't work on first boot, a restart wakes them up (sometimes) but if you take your headset off or use hand tracking then try to go back to the controllers they seem to go on holiday!

Best advice I can give is if you are on PTC (public test channel) to disable that and unfortunately factory reset back to v64 (I know that's a total nightmare)

Luckily having the Quest 3 I reverted back to the standard controllers.

Kind regards


Quest 2, Quest 3, PCVR, Meta Wayfarer

Meta Quest Support
Meta Quest Support

Hey @Dune_Cat & @J40NYR! I noticed you were both having issues with Quest Pro controllers—with one of you being on the PTC, so I wanted to get a bit more information to see if this might be an issue to raise to engineering to look into!

  • Can you provide your current headset version number?
    • You can check in Quick Settings > Settings > Software Update under the Current Version Details section. The formatting should be 65.#.#.###.###.#########.
  • Have you already attempted a factory reset on your headset and/or your controllers?
  • Does the issue still happen when switching to another wi-fi band entirely?
    • 2.4Ghz tends to be pretty congested, so 5Ghz or 6Ghz may end up helping with interference.
  • Have you tried cleaning the sensors on the pro controllers by following our product cleaning guide?
  • What about unpairing and re-pairing the controllers in the mobile app?
  • Does your play space contain any other objects that may cause interference?
    • Microwaves, baby monitors, cordless phones, other Bluetooth devices, reflective objects, etc.?
  • Have you found any workarounds that might be worth sharing?
Technology, at a certain level of sophistication, is indistinguishable from magic. - some wise guy or something probably

  • Headset Version:
  • I have tried factory resetting the headset
    • I have tired factory resetting the controllers
    • I have REPLACED the controllers
  • It still happens when completely disconnecting from WiFi networks (but leaving WiFi enabled, as it seems to complain that it'll cause tracking issues if I do, so I leave it on... and still get tracking issues)
  • Not only have I tried cleaning the cameras, I've even REPLACED the whole controllers
  • Not only did I try un-pairing and re-pairing the previous controllers, I also REPLACED the, and the new ones do it, too
  • Microwave is in the area, but off during the issues. I'd maybe believe the "reflective objects" in the area thing, except it seems to be too intermittent and seems more likely to happen during "peak" internet usage time for neighbors.


I haven't really found good workarounds, other than trying to disconnect from WiFi completely, which seems to help SLIGHTLY.

Moving my usage of the headset to "off-hours" times when WiFi use around me (on other networks) is low has also seen success.

I'd love to see logs or debug logs from the headset or controller that might help confirm (or dis-confirm) that this is some connection issue with the controllers. Are they channel-hopping at the time of the disconnection? Seeing high retrans rate? Disconnecting and reconnecting? Anything would be helpful, but nothing seems to be available.


Thanks for the info! It'll be hard to discern the exact cause of interference without having the proper teams look into it. For emerging software issues, engineering will have to look into replicating it to see what might be causing the problem. Before that, I noticed you were still on V63, which is a previous version of the current V64.

Are you able to update your headset to confirm if the issue still happens on a newer version? It's likely that your controllers are still on older firmware, which could be causing tracking issues. 

Technology, at a certain level of sophistication, is indistinguishable from magic. - some wise guy or something probably

I'm getting the update installed now (or, I think I am, I clicked install, and it said "Installing..." but gives no progress, and navigating back to that page just gives some "software version" and no indication that it is updating or updated (and the "Restart to apply update" button is greyed out)... so I'm letting it sit a while for now.

I'm doubtful that a new version will fix it, and it is HIGHLY unlikely because "[my] controllers are still on older firmware", this issue has persisted for a few updates (headset and controllers) at this point. Each time I hope it magically fixes it, but it doesn't.

I want to also note that connecting to WiFi (because I have auto-connect disabled I have to tell it to manually connect) is incredibly flaky as well (and even when it was auto-connecting, it would sometimes just fail to connect a few times before eventually connecting). But as it is right now, I'll click connect and it doesn't even show indication of connecting, but a little bit later I get a "connection failed" popup. If I toggle WiFi on/off, suddenly clicking "connect" seems to work without issue.

If the controllers do, in fact, use WiFi for communication to the headset, I'm wondering if there's a WiFi driver/firmware issue at play here?

Meta Quest Support
Meta Quest Support

Thanks for confirming that! Did the update end up going through to the latest V65 update? If not, or if the controllers are still experiencing issues, I recommend reaching out to @MetaQuestSupport in a PM. It could be that the headset itself is the culprit, given the connectivity issues—along with you already trying new controllers.

Technology, at a certain level of sophistication, is indistinguishable from magic. - some wise guy or something probably

Unfortunately, the issue still persists, like it has with other updates to the headset/controllers. It got pretty bad this evening, too (to the point I just gave up trying to deal with it).

Is there any way I can pull logs (debug or otherwise) from the device/controllers? I mean, I'm literally a System Development Engineer and Linux Sysadmin (and user), I'm not scared of a little log-diving on an issue, just need to know where to find them (before I just start blindly poking about with ADB). It would be great to see if I can confirm connection issues or interference or really anything about the issue.

Thanks for giving that a try. As for logs, what you're looking for might be the Diagnostics logs you can pull after connecting your headset to your PC.

  1. Find your Meta Quest Link App installation directory (C:\Program Files if installed on the primary hard drive).
  2. Navigate to the Support file and then oculus-diagnostics.
  3. Select OculusLogGatherer and wait for the executable to appear.
  4. Select Get All Logs.

I highly recommend checking your warranty options on the headset itself with @MetaQuestSupport, as any modifications made with ADB may void your limited warranty.

Technology, at a certain level of sophistication, is indistinguishable from magic. - some wise guy or something probably

Honored Guest

I’m also having issues! It has taken me a few weeks to find this thread, but it started suddenly about 3 weeks ago. Did you get a resolution? 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?