cancel
Showing results for 
Search instead for 
Did you mean: 

Quest Pro Developer Mode

cpvr.stud
Honored Guest

I tried to enable developer mode on the Quest Pro following this tutorial:
https://developer.oculus.com/documentation/native/android/mobile-device-setup/#enable-developer-mode

 

The last window "Allow USB debugging?" is not showing up.

I did it on Quest 2 and everything works fine (in my opinion the pc should be ok).


I'm using the official Link cable.

Is there a specific Quest Pro driver that I need to download or a manipulation that I need to do ?

Thanks

 

11 REPLIES 11

thnk2win
Honored Guest

Same issue here. It also took many attempts on both Mac and Windows to get past the first couple of screens connecting the device in Developer Hub. It would see the device and I'd click to the next step but it would spin forever and never complete. Eventually on Windows I was able to get all the way through it but then the permissions dialog never shows on the Pro nor do I see anything in settings to enable it. So the Pro never shows up in the devices list in Developer Hub.

RIP. Are you able to view the headset in MQDH now? Does it matter if the device doesn't show up in Developer Hub?

Ryantg88
Expert Protege

Your wasting your time!... Oculus team are fully aware of this issue and are not willing to give any type of ETA or description of the problem. They're not even willing to recognise this as a global problem and register the issue on their website...

Honestly anyone who post a comment you are absolutely wasting your time.

Head here to learn more on page 30 onwards. 

 https://forums.oculusvr.com/t5/Get-Help/Known-Issue-Error-saying-quot-We-re-having-problems-loading...

 

Post your thoughts to :

tips@roadtovr.com

tips@uploadvr.com

IGN submit Tips - https://corp.ign.com/contact -

tips@engadget.com

contact@eurogamer.net

Hey there, @sachinreddy1, We completely understand how this is affecting your VR experience, and we'd like to get this resolved as soon as possible. Currently, we're having an issue with some users not being able to enable the Developer Mode. We're actively investigating this issue, please keep an eye out on the Developer Status website as all further updates regarding this issue will be announced via this site.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

@MetaQuestSupport it appear the Developer Mode issue has been resolve (though I strongly recommend someone from your team update the documents to state that two verifications AND a credit card must be on file, as I spent far longer that necessary troubleshooting this). However, now with Developer Mode active, every possible driver updated, reset this, uninstall that and I still can't get the "Allow USB Debugging" to pop up, so I'm unable to sideload/ test - lots of frustration and wasted time. Can you offer any workarounds?

did you happen to get this resolved I'm still screwed

This developer mode issue that was on-going within this thread had been solved, @ChrisQuitsReality. If you're having issues with this setting now, please make sure your device is updated to the latest version and perform a power-cycle as well.

If this issue is persistent after verifying you're updated and cycling, you may need to Submit a Ticket with support. You'll be able to get further assistance through that support channel.

In the time of your life, live - so that in that wondrous time you shall not add to the misery and sorrow of the world, but shall smile to the infinite delight and mystery of it.

P.S., I can beat you at One Piece TCG and Tekken

It does not work for me either. Everything up to this step works and the people in the support chat can't help me either. Have you found a solution?

NoarExperience
Honored Guest

I got the same issue and can solved just changing the official link cable, instead of it I used a cable with USB type A terminal.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?