Showing results for 
Search instead for 
Did you mean: 

Quest Touch Pro controllers stuck on 'Update starting...' after Quest2 firmware update


After my Quest2 headset firmware auto update to v60(50686620043000150), it prompt me my controllers will start updating, double controllers are purple lighting, and then just stuck on 'Update starting...' (the progress bar like "0%" not appear). In smartphone app the firmware of controllers is 1.23.0

And I find if I turn off the wifi function of headset or cut off wifi link, avatars of the controller will appear and work in 3dof mode; but when wifi connected, it disappear and not working.

I forgot what version was before the firmware was automatically updated, but it should be v55 or earlier.

I tried:

1. Restart headset

2. Change the channel of wifi from 157 to 36

3. Use wifi from other routers

4. Repairing controllers in smartphone app

5. Restore factory settings on controllers

6. Restore factory settings on headset

But all useless.

It should be something wrong with wifi in new firmware, I hope it could be fixed as soon.



I'm tired and desperate. I tried everying I can image, use 2.5Ghz wifi, use smartphone hotspot, change the tracking frequency of headset, only pair one side of controllers and tried to update controller, reset factory then use adb sideload to downgrade to v56 (failed, total xfer 1.00x).

And all wasted.

@MetaQuestSupport  now I think you can tell me all my efforts I did and I will do are no use and all I can do is waiting for the next firmware update hoping this bug may be fixed?

The worst experience.

Still haven't found anything useful today, maybe questpro was totally forgotten by meta.

Community Manager
Community Manager

Hey @a324260327! We know how important it is to have a working set of controllers, so we'd be glad to get a better look into this for you. 

We do apologize for our delayed response, but we do see you've sent a PM. We'll be continuing through there as we may require some sensitive information. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!