cancel
Showing results for 
Search instead for 
Did you mean: 

Quest can't connect to PC over AirLink

bigjrod
Level 2

I have been able to connect using AirLink once before, but trying it recently does not allow the Quest to connect. When trying to activate AirLink, my Quest recognizes my PC, but gives an error about being unable to connect. All software is up to date on both the Quest and my PC. I have tried restarted both multiple times. Both are connected to the same Wifi. I've tried using the Mac Address for the Quest to ping it from my PC, but I doesn't show up, even though both are connected to the same network. I even factory reset my Quest to try to fix this issue, and it did not work. I was able to go through the pairing process, but unable to launch AirLink.

13 REPLIES 13

MetaQuestSupport
Community Manager
Community Manager

Hi @bigjrod! Let's work together to get Air Link working once again. First off, we'd like to ask a couple questions:

  • Does your Quest 2 work properly when not connected to Air Link?
  • Is your PC fully Link compatible according to THESE specs?
  • If you have a Link cable to test, does it connect to your headset?

I am using the original Quest, and my PC is fully Link compatible. I have a Link cable, and it does connect to the headset, and I am able to Link using it.

Thank you for the update. 

 

There are some other questions we do want to ask:

 

  1. Did anything change around the time when this was first noticed?
  2. Are there any extenders on the network? 
    1. If so, please be sure they're both on the same network device.
  3. Do you have any VPNs active on the PC? 
  4. Is your network running at 5Ghz or 2.4Ghz?

 

We look forward to your update! 

Hey again, @bigjrod! Just checking in to see if you were still in need of some assistance. 

 

If so, please don't hesitate to reach back out! 

Having basically same issue.

Was working previously. Motherboard died. Replaced.
Also PC was upgraded to Windows 11 Pro from Windows 10
PC App on,after selecting Wirelsss Headset, Screen saying "Connect to your Headset" ... waiing for connection icon to go green I guess.
PC Firewall and autoprotect turned off.
PC connected to Internet via LAN but also connected to WIFI on 5GHz as previously.
Phone is connected same Wireless 5Ghz Network.
Meta Quest 2 Headeset on same Wirelss 5GHz Network.
On Headeset, Connect to Quest Link Air Link enabled... just says Searching for PC's with a spinnig Wheel.
Never finds anything.
It will work with a link Cable but cannot get Wireless link to find PC?

Hey @RIP_IT, we want to make sure that you get the correct support with us, so that you can get back to gaming freely. We might need to do some extensive troubleshooting so it would be best to contact our support agents over chat and email. You can do so by following this link here

When I go to the link and select support, Headset, none of the options are connection related

We are aware that the resources available on the help page are general issues and are occasionally quite generic. You can reach the oculus link support case by following this prompt: 

  •  Quest2 > Accessory > Oculus Link> Air Link  ( however, the website will only issue a support ticket via email this way.) 

You could also try: 

  • Quest2 > Headset > Display> Stuck on image > This does not solve my issue. 

This will cause the website to send out a contact form with a variety of service options. We do hope that our representatives are able to help with your issue and get you back online. 

Hey @RIP_IT, we want to make sure that your issue was resolved and you're back to playing happily. If you are having any trouble please let us know.