cancel
Showing results for 
Search instead for 
Did you mean: 

Quest link not working with Quest 3

StonedMagician
Explorer

I just updated my Nvidia driver to the most recent version (537.58), and now Quest link just isn't working at all. Tried uplugging and replugging the link cable, nope. Tried restarting the headset, nope. Anyone else having this problem?

1 ACCEPTED SOLUTION

Accepted Solutions

TheAntiSocializer
Meta Quest Support
Meta Quest Support

Hey everyone! The engineering and product team has reached back out to me and provided an update. 

It looks like they won't be able to get the necessary information through here on the forums, but they did want to look into everyone's logs to get a closer look. I highly suggest testing out PTC and if that doesn't work, reaching out through a support ticket so they can gather the logs and provide some more in-depth assistance. 

Sometimes it's okay to be a little Bing Chilling

View solution in original post

118 REPLIES 118

therealcberns
Protege

Yes. I am having the same issue. The link works on my quest 2. So I know the cable and connection can and does work. Quest 3 never says anything but “pc disconnected”

I have developer mode enabled. I don’t have the beta version cause it works for my quest 2. I don’t want to mess it up for both

Schwing27
Honored Guest

Yup. Same issue for me.  It worked right at first. But when I got home from work and tried it again it’s been nonstop issues. This is frustrating. 

Hey everyone, thank you for reaching out about this issue with your Quest 3 and PC VR. While we do expect to see some bugs during launch week, we'd like to see if everyone has tried the same troubleshooting steps.

Can we all confirm that we've tried the following steps?

  • Make sure the graphics card drivers are fully updated.
  • Make sure the PC app is fully up-to-date.
  • Make sure the Quest 3 headset doesn't have an update available.

We'd also appreciate it if you could all send a bug report. Feedback is important to us, and we appreciate everyone's time and patience.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

therealcberns
Protege

I have updated the nvidia 3080 graphics card, updated the PC through settings (windows 11), flashed the motherboard bios to most recent available, checked quest 3 headset, updated USB drivers, and did the developer hint for the previous link issue.

I have a quest 2 and it works right away when I plug it in. When I plug in the quest 3, it says USB not recognized,  malfunction error. Is my quest 3 a lemon?

Thank you for getting back with us, @therealcberns. Would you mind testing to see if the air link works for your Quest 3? If so, would you mind letting us know what brand of cable you are using for Link as well? Is it our official cable or a third-party brand? Thank you in advance for your time testing this! If you're still having trouble, send us a private message so we can get into more detail. 

In order to PM us, all you need to do is select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember that you must be signed in to the community first to send us a private message. We look forward to hearing from you.

 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

It works with airlink. The Quest 3 just will not connect to the PC with a cable. 
It is a meta usb c cable. The cable works fine with the Quest 2. Even right this second. It will just never connect to the PC when plugged into the Quest 3. Says the device is not recognized. Like something is wrong with the Quest 3

This is very interesting. Thank you for trying all of these tests. Just to be sure, is this the official Meta Link cable? If you don't mind, please send us a private message, and we'll be able to assist you further!

 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

jools.245034
Explorer

Quest 3 arrived yesterday. Spent about an hour trying to get it to connect via cable, exhibiting behaviour below with it endlessly looking for PC. It eventually did connect via the cable and I had a brief go at a few games, I don't know that I did anything different to the other times I tried to get it to connect.

I went to try again this morning and it won't connect again. Tried for 2 hours no joy.

In the Quest 3 interface it's searching for PCs forever, on the PC it's on this screen forever

jools245034_0-1697121580264.png

Some things I've tried/checked

Rebooted/Restarted multiple times. PC, Quest 3, Oculus software

Factory reset the Quest 3

Put the Quest 3 into developer mode

USB ports are SS and I've tried different ones.

Under device manager all USB are set to

jools245034_1-1697121683453.png

Under power settings this value is disabled

jools245034_2-1697121719013.png

 

There are errors in the event viewer under Custom Views/Administrative Events when I try to connect the device via cable

jools245034_3-1697121998421.png

There is an error in the Device manager when it's connected via a cable

jools245034_5-1697122067223.png

 

jools245034_4-1697122027871.png

Under Events is the following

Device configured (usb.inf)

Device USB\VID_0000&PID_0002\6&86bc4a1&0&3 was configured.
 
Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 10.0.19041.3570
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILURE
Outranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: false
Parent Device: USB\VID_05E3&PID_0610\5&153678d8&0&5
 
Followed by Device not started
Device USB\VID_0000&PID_0002\6&86bc4a1&0&3 had a problem starting.
 
Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Service: 
Lower Filters: 
Upper Filters: 
Problem: 0x2B
Problem Status: 0x0

 

Airlink I assumed was working as that connects right away, it says the PC meets the specs and there are all green ticks when you do the diagnostic check. But clicking launch I get 3 dots forever or a black screen. But the main thing I want to work is the link cable.

The link cable I'm using is https://www.amazon.co.uk/dp/B0BRQHN5MY?psc=1&ref=ppx_yo2ov_dt_b_product_details

Talking to a guy in support he asked me to run C:\Program Files\Oculus\Support\oculus-diagnostics\OculusLogGatherer.exe and send the resulting Zip.

I can't attach that here but can provide any files from it.

Any help appreciated.

Gavin

 

 

Oh yeah the Meta Quest App is on the latest version.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?