cancel
Showing results for 
Search instead for 
Did you mean: 

Quest link not working with Quest 3

StonedMagician
Explorer

I just updated my Nvidia driver to the most recent version (537.58), and now Quest link just isn't working at all. Tried uplugging and replugging the link cable, nope. Tried restarting the headset, nope. Anyone else having this problem?

118 REPLIES 118

Hi dude,

Hope something in here works for you, but unfortunately it didn't for me. I think it's just a waiting game at the moment till META get their act together. I'm giving them till April and if any of this is still a thing then it's Pico 5 time and Ebay for META

TheAntiSocializer
Meta Quest Support
Meta Quest Support

Hey everyone! The engineering and product team has reached back out to me and provided an update. 

It looks like they won't be able to get the necessary information through here on the forums, but they did want to look into everyone's logs to get a closer look. I highly suggest testing out PTC and if that doesn't work, reaching out through a support ticket so they can gather the logs and provide some more in-depth assistance. 

Sometimes it's okay to be a little Bing Chilling

Recently I gave in and bought the Quest 3 to play games with my bros, however since I've pulled it out of the box Quest Link has given me nothing but problems. Air Link frequently stutters and tears, and while using a highly rated usb 3 Link cable, my screen shows an error symbol, then the colors are mega saturated and whenever I try to move my cursor the screen blacks out. All my drivers and programs are all up to date, please help

Thank you, this actully helped me be able to plug my headset into the computer and transfer my music files to tribe XR.

Woritmor
Explorer

Thank you very much @therealcberns and @Sandalwood777 . 

I also have an ASUS Motherboard and (nearly) the same Issue as discussed here (My PC is listed but when in want to start Quest Link it worked like one time and then, if I try again, I only see a black screen and the three white dots an Quest link didn't start)

I updated these three Drivers for my ASUS ROG Z790 Hero:

Intel ME Consumer V2334.5.1.0 (SW 2335.5.26.0) For Windows 11 64-bit.
Intel Chipset driver V101196008418 for Windows 11 21H2 64-bit.(WHQL)
Intel DTT 9.0.11401.38310 (Ipf driver V1.0.11401.38408) For Windows 11 64-bit.

as well as BIOS to Version 1402.

And now it seems to work fine.

So, one of these 4 fixed it for me. 

 

When I first used it in quest 3, sometimes it would recognize it or sometimes it would just load. After many attempts I realized that when you connect the cable, a message appears on the lenses "if you want to activate the USB". If you click on the message it will immediately recognize the cable and the PC will recognize the lenses

lol noticed that too. it only popsup when you restart your meta quest 3 as well.  so once that notification pops up. i click allow then the headset will continue to connect for the rest of the day till i turn it off to charge.

Djaydenhokken
Explorer

I'm trying to air link and connecting to the oculus app with my vr but my laptop just doesn't show up.

Same, I think it’s a bug that came in v57 because it’s happening to everyone else with a Quest 3.

oh ok thx cus i thought it was maybe cus i have a laptop and it works with my brother's pc cus he maybe had like a setup or something

and if i connect with his pc it says: "PC:(name of pc)"

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?