cancel
Showing results for 
Search instead for 
Did you mean: 

Quest link not working

zaeblade
Honored Guest

Hey there. this is sort of a rant post at this point

I have done EVERYTHING imaginable to try and fix my headset to connect to my pc via link a=cable as well as air link. nothing seems to work.

ive tried factory resetting, reboots, every troubleshooting thing you can think of. and still NOTHING will work. ive been at it for 9 hours already today trying to figure this mess out. and meta doesnt do anything to help, its just suggestions after suggestions of things ive already done, getting me to send them a log of my stuff every time, and having to wait HOURS for a response via email. its ridiculous at this point. 

i  guess my question is, doe anyone know what to do? im terribly stuck now.

19 REPLIES 19

synchromesh62
Expert Protege

Same for me on the Desktop App
It sees my Desktop1 and says not connected and will not let me pair the Quest 3 and PC or launch .. Happened on my Mrs Quest 2 as well. 
My phone sees the devices ok when they are switched on ?

Hi, @synchromesh62 / @zaeblade! Thanks for bringing challenges with Quest Link to our attention. To best advise and reestablish the Quest/Air Link connection successfully, answer the following:

  • Is your PC is compatible and meets our minimum Requirements
  • What error message(s), if any, do you see?
    • Which step(s) exactly would you like help with Setting up Meta Quest Link?
      • Don't forget to disable AirLink
    • Has the connection ever worked and does the device/app work standalone?

We'll stay tuned as we're eager to assist further. Keep us posted!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I have been using airlink on the Quest 2 and Quest 3 since i had them, Quest 3 since day of release with no problems whatsoever. Any ideas and I'm all ears 🙂
Woke up today to see not connected and my PC and launch buttons ghosted Out
Tried everything so far i can think of and it does not even see the my Quests turned on in the Desktop App
It does however in the Mobile App.

Its all very strange ... Anyone else ?

Q1.pngQ2.png

Ok, good @synchromesh62. So the Quest Link worked for both devices up until recently? Good to know, thanks for the details/screenshots! The next steps for us to reestablish the connection are as follows:

  • Repair the Meta Quest PC Application
    • Click Download software
    • Select Repair
      • If Windows asks you if you’re sure you want to open this file, click Yes
      • If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway
      • If your antivirus software restricts the file from opening, temporarily disable your AV and continue
      • Please remember to re-enable your antivirus software once you've completed the repair
    • Allow the repair process to run, download and install.
    • Launch the Meta Quest PC app
  • Confirm that your drivers and Windows are up to date

Afterwards, let us know if the repair/update allows you to connect again or DM us privately to collect your logs.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

i get no error message, i just click for the link/air link to work, and it says connected and everything on my pc but never brings me to the actual screen showing it, only shows me a black screen with three dots

Understood, @zaeblade! First, confirm that your PC meets our minimum Requirements and if Quest Link worked previously. If so, review the steps below to help reestablish the connection:

Keep us posted afterwards if/when able to rekindle your connection. Otherwise, DM us your logs in private for further review.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

it has worked before, and ive already done that twice 

Nice, @zaeblade! You've repaired twice? Are your drivers and Windows OS up to date? If you've repaired, check to confirm that your drivers and windows OS is up to date next. Both critical to "set up Meta Quest Link." Up to date software and the USB-C 3.2 cable supporting 5GBs or higher is half the battle. We'll stay tuned here before moving offline if necessary. All the best!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

yes ive checked multiple times if my drives and windows are up to date

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?