cancel
Showing results for 
Search instead for 
Did you mean: 

Quest pro headset not charging

ZEROPHILOSOPHY
Level 3

When I plug my quest pro in I get the meta logo followed by the battery with slash  icon  then everything goes dark I plugged it into the wall with the supplied c-c cable and adapter , also tried 2 other cables and have tried charging from a c port on the pc. It hopefully isnt a faulty cable and just some software glitch. Please let me know what i should first try before calling meta for a refund. 

2 REPLIES 2

MetaQuestSupport
Community Manager
Community Manager

Hey there @ZEROPHILOSOPHY! We understand you're having issues charging your new Quest Pro. That's not the kind of experience we want you to have. Rest assured, we'll try to get this fixed so you can continue to enjoy your new device!  

 

Please make sure to remove the cover before placing the headset on the charger. Also, have you tried any different outlets?

 

We're providing a link here on how to setup your device for charging.

 

Let us know if you have any other questions.

MetaQuestSupport
Community Manager
Community Manager

Hello. We're just seeing if you were still needing our assistance. Please let us know!