Showing results for 
Search instead for 
Did you mean: 

Quest3 V65 Cable Link is not detected by PC


Quest3 after last update to V65 not working with cable link connection.
Before update everything worked fine. Goggles via Virtual Desktop are working normally.

Device can not be added in Meta Quest Link application - I tried it multiple times without success.

- Cables swapped and connected to different USB-3 ports (USB-A and USB-C).
Both cables and both USB ports worked fine before update. Cable link is still not detected,

- Meta application reinstalled.

- Goggles - factory reset performed,

- Graphics driver - the newest one is installed

- Windows 11 (23H2) 64bit - up to date,

Do you have any suggestion what can I do more?

Software update/system version 49941090063600510
Runtime Version
OS Version SQ3A.220605.009.A1
Meta Quest Link App Version (
PC specs:
AMD Ryzen 5 5600X 6-Core Processor 3.70@4.65GHz
Graphics MSI RTX 3060 Ti Gaming Z Trio LHR
Memory DDR4-3603/PC4-28800 DDR4 SDRAM UDIMM 32GB
Motherboard MSI MAG B550M MORTAR (MS-7C94)




same here , after v65 update Meta Link no longer working. :((   
I tried new cable, tried reinstalling Meta Link software,  and removing the headsets in the software.

I also can't add my Quest3 anymore now in the software,   as it asks to plug in the headset via USB, but when I do that , the software does not detect that and keeps the Continue button greyed out!

Please Meta, bring out an emergency update soon,   as my Quest3 is now an expensive paperweight! 😉

I would like to ask you about your cable link - did you use genuine cable from Meta or other manuafacturer?
I have checked my Q3 goggles on my friend's PC with Meta cable and they worked immediately after connection. When we connected my cables (I have two) to his PC they didn't work.
So, it looks for me that Meta changed something in their software (intentionallyor not) what recognizes genuine cable and discards another manufaturers. Maybe I am wrong, but that is suspect why everything worked earlier and stopped after V65 update.

thx for the tip!    I'm using a third-party cable... I own the original cable but it stopped charging my Q2, hence I switched to a third-party one because I didn't trust the original to be sound.... Never had any issue w the 3rd party cable until now.

I was able to re-add another Q3 (the one from my son) with my same third-party cable. But his Q3 was still on v63 however, so this also supports the working theory that they changed something in v65 that makes it so only original cables are usable...

Then I tried the original cable and it didn't work. now when I switch back to the other cable (or any of the 3 other 3rd party cables I have) none of them even detect in the Meta Quest Link software (the updated one , v65).

They really must have screwed something up in this release...
It's ashame , when it works fine it's nice, but always after a few weeks or months something needs to be broken and we can spend some days or weeks without it working propperly (or at all ) !  Meta , TEST your releases better in order to not be breaking stuff that worked fine before!!!

It's not necessarily an issue with 3rd party cable. I have the same problem with a Quest 2, and I tried everything described above, without any luck, on two different computers. Then in last resort, I did purchase the Meta cable, but it didn't help. I think my problem is a hardware issue, as the connection became unstable over time, then finally died completely. I'm trying to get the headset replaced (Under warranty), but I do have communication issues with Meta as well. Meta doesn't even list the Meta Link in their service options, and they gave me the instructions to pair with Airlink! I've wasted so much time with Meta support...

I think there's a broader set of issues related to the USB connection. My Quest 2 connection issues started several months ago, and the USB Test would give me an 'unstable connection issue'. I had a similar problem with my Rift S, but the work around was to disconnect, then reconnect the USB. I tried on different computers, even purchased the expensive Meta cable and an USB 3.0 card. Now the connection is totally dead, struggling to get Meta customer Support (Under warranty). Reading through the forums, it seems that Meta's support for the Quest Link is a low priority. Meta suggested that I use Airlink, which obviously is not adequate for flight simulators (We use the Quest for training real pilots). I will probably switch to a more professional, but more expensive product. 


@Sil3k  If everything was working fine prior to v65 with your Q3 and Link, I'm not sure why it stopped working now?  All my Quest headsets (Q2/3/Pro) are working very well with v65 using my official link cable (connected to my z790 usb3.2 type-c port).  Air Link and Virtual Desktop (with my wifi6 AX router) are also working fine.  So, I don't think that this is a Meta software related issue.  Most likely a hardware and/or win11/nvidia related issues imho.

If your cable was working fine before it still should still work fine.  Still might be a good idea to test this out with another usb device.

Some win11 updates can change usb settings so you may want to check that your usb ports (device manager usb properties) do not have any power savings enabled and their drivers are up to date.  Also, make sure your headset battery is fully charged (or at least 80%) before using Link and disconnect any unnecessary usb devices so you don't run out of usb bandwidth (and maybe power delivery as well).

Other minor things I'd suggest is to go to your windows graphics setings and disable hardware graphics acceleration (HAGS).  I've often found this can cause problems with PCVR.  With nvidia driver updates I've found using DDU in safe mode to properly uninstall the previous driver helps (google how to do this) and I avoid installing nvidia geoforce experience.  Go to your nvidia control panel global 3d settings and set everything to defaults except power = prefer max performance and change the Quality default below that to High Performance.

The order you connect my Link cable seems to matter as well.  I've found it best to startup the meta link pc app, then startup the headset without the link cable connected.  Then plugin the link cable to the headset.  You should get a notification that this is connected.  If not, try disconnecting/reconnecting the headset connector and try again.

Sorry, all I can think of right now mate.  If you still cannot connect your Link cable to your Q3 then I suggest you contact Meta support, including your log file, and see if they can help.  Good luck mate and cheers.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers


so I uninstalled all unused USB device drivers, using USBDeview

and also in Device Manager, I uninstalled the Oculus Device -> Oculus XRSP Interface ...

I then got it to connect again when plugin in the Q3 via my 3rd party cable (which is working fine when tested w other device).


The Oculus XRSP Interface appeared again in the Device Manager...
is this a good thing or bad (we are not supposed to click allow file transfer according to Meta, but I did that anyway , and now it stopped asking , and so not sure this XRSP Interface installs because I told it to do the file transfer via USB).


When launching SteamVR after having enabled Link however, SteamVR fails to launch and says:

A key component of SteamVR isn't working properly. (301)

I'm now at a point where I suspect the V65 is not playing nicely with SteamVR anymore for some reason...

I tried both the regular SteamVR and beta version, both giving this same error.

Also while I am able to connect Quest3 via USB3 cable, but when in Oculus Link software I try the cable test, it says it's unable to start the test...


is it not possible to download a previous version of Meta Quest Link (v63 or v64) somewhere??
I searched but could not find it...


and one more thing, it's not just SteamVR not working...  also when I try and launch an Oculus title from the Meta Quest Link software (from Library), it doesn't work....     For example Art Plunge it launches but only shows on my desktop monitor, and not in the headset.     Google Earth VR  doesn't launch at all.

I have also done a factory reset of my Quest3 just now, didn't solve the issue
(so def. not a Steamvr issue rather a Meta issue I think)

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?