cancel
Showing results for 
Search instead for 
Did you mean: 

Question in regards to WINUSB failed to initialize.

Puppylotion
Protege

Hi! 

I just posted a potential solve for stutter, audio crackeling and shimmering that seem to plauge pcvr. The reason i'm mentioning it is because of that tedious adventure i've found that some things fail to initialize when starting the oculus services and i have questions. I'm refering WINUSB in perticular, but there are more things that seem to fail if you want to look into it. (debug tool > services > make console visible)

So, my thought process at the time was that winusb might be the reason for why the usb 3.1 gen 2 port only show up as 3.0 and only deliver 1.5 Gbit/s. This is obviously not the case for me as there seem to be some sort of bios problem and i don't think others achive higher speeds than around 2.2 gbit/s to the quest. 

Anyway, WINUSB failed to initialize because of lack of memory. I have plenty of RAM so it probably has to do with the memory windows allocates to the process. So i doubled the maximum allowed heap allocation in regedit, as you do, to no effect.

So my questions are: What is WINUSB respossible for? And is there a benifit to getting it working? also, is there a way to globaly change OpenXR settings or can i only do it on an app per app basis?

23 REPLIES 23

MetaQuestSupport
Community Manager
Community Manager

Hey there, @Puppylotion. We appreciate when our users want to know the ins and outs of our headset, and we always try to provide an answer that meets their needs. With that being said, we know how important it is for you to determine why your USB 3.1 had some issues finishing initialization. We know you said you had plenty of memory, so we can rule that out. To see if we can get the issue resolved, we would like to share some steps to clean your PC. Those are as follows:

 

1. Disconnect the Rift/Link cable from the computer.
2. Disconnect your computer from the internet.
3. Backup any necessary content. You can find steps on how to do so by clicking here.
4. Reboot into Safe Mode. You can find steps on how to do so by clicking here.
5. Uninstall the Oculus PC app using the Control Panel. You can find steps on how to do so by clicking here.
6. Delete all Oculus folders from the following folder: C:\Program Files
7. Remove any Oculus folders from the following locations:
C:\Users\YourUserProfile\AppData
      C:\Users\YourUserProfile\AppData\Local
      C:\Users\YourUserProfile\AppData\LocalLow
      C:\Users\YourUserProfile\AppData\Roaming
      C:\OculusSetup-DownloadCache
8. Restart your computer in normal mode.
9. Reconnect your computer to the internet.
10. Install the Oculus PC app again using the setup tool from our website here.
11. Reconnect the Rift/Link cable and re-test the headset.

 

Please let us know if this worked for you, and if we still need to work together to find a solution, we can go that route as well. Thank you for your time and patience, and have a wonderful day!

 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hi again, @Puppylotion. We wanted to touch base with you to see if you had been able to perform the steps we provided or if you still needed assistance with your PC issue. Please reach back out to us and let us know how your progress is coming along.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi! Thank you for the advice!

I haven't had the time to try it out yet, I'll get right on it tomorrow afternoon. In the meantime; Would it be possible to know what WINUSB is responsible for? And as i've noticed that framethrottle introduces stuttering i was hoping there was a way to change the OpenXR setting globaly rather than on an app by app basis.

Thank you in advance. Will report back tomorrow.

Hey again! Not to worry; take your time, and we'll be here ready to move forward. As for your questions about WINUSB and the framethrottle introducing stuttering, we think those would be better suited for our developer forums, which can be found here. We do hope to hear from you soon regarding those steps previously shared! Until then, have a great day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi! I tried all the steps you suggested and things still seem to fail to initialize. Here are the screenshots from the console if they help ^^.

Screenshot 2024-01-19 152349.pngScreenshot 2024-01-19 152339.pngScreenshot 2024-01-19 152327.pngScreenshot 2024-01-19 152310.png

Puppylotion
Protege

Well, i installed other drivers to a usb hub that doesn't use winusb. When winusb isn't used by the server i can get most of the stutter in games to go away.

 

Puppylotion
Protege

So, winusb can only interface with one interface at a time which introduces stutter. 

Please enumerate the appropriate driver to \\?\usb#vid_1004&pid_62c6#vs12345678#{a5dcbf10-6530-11d2-901f-00c04fb951ed. I think it's the XRSP that deals with the streaming. Even composite drivers are to much for winusb to initialize.  

MetaQuestSupport
Community Manager
Community Manager

Hey @Puppylotion. We see that you may have found a workaround for this issue. If so, let us know. We would love to have a solution for other people in the community. If you are still in need of assistance, we would be more than happy to continue diving into this with you. Talk soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Puppylotion
Protege

Removed

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?