Showing results for 
Search instead for 
Did you mean: 

RTX 4070. Your system's graphics card is incompatible with the Rift system software...



I've got a new XPS laptop (2023) with an RTX 4070, i9 CPU, 64GB ram, win 11 and have been chatting with support and still get this message when I open the PC oculus app. Already went through the standard support channel and submitted logs and manually assigned the high-end card to this app and the issue still persists. Has anyone been able to resolve this? Thanks for reading and your consideration.


Accepted Solutions

Meta Quest Support
Meta Quest Support

Hey everyone! Just jumping in here to state that I'll be locking this thread. The reason being that this is a bit of an older thread. We do have a more recent thread right here that I'd definitely suggest reaching out on if you're continuing to experience some issues. 

As for the error message, our Link requirements do state the 40 series as supported so the error may state it's incompatible while still working properly. 

Sometimes it's okay to be a little Bing Chilling

View solution in original post



Anybody here?

Community Manager
Community Manager

Hey, @pj39Jameson! That's quite the beefy laptop you've got there! From the specs alone, it seems like it should be compatible with our Oculus software. We'd love to take a crack at helping you get it all set up and figured out! Seems like you've already got a support ticket submitted with us based on what you've mentioned. Mind sharing the ticket number with us for your active support case, so that we can get up to speed?

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

05791624. If it has expired, let's start a new one. I would love to get this issue resolved.

We're right there with you, @pj39Jameson! Seems like the ticket had been closed out for some time, due to system automation. Typically, our system flushes out cases where a response was never received from the user after some time has passed. No worries, as we'd love to help out with your PCVR issue here!


Since you last reached out through our support channel, there's been a new Nvidia driver version for RTX 4070 (Notebook) GPUs. Version 546.17 - Release Date: Tue Nov 14, 2023.We recommend updating your drivers, and Windows (if applicable), then restart your laptop before getting started! Since it's a newer laptop, we also recommend making sure you have the proper .NET Runtime and Visual C++ Redistributables packages installed.


After that, try installing a fresh version of the Oculus software. This is a method for uninstalling the Oculus desktop app to ensure all relevant data has been removed from the machine. The normal uninstaller may not remove a file that is causing problems, so this is similar to a "factory reset" of sorts for the Desktop App.


1. Disconnect the Rift/Link cable from the computer

2. Disconnect your computer from the internet

3. Backup any necessary content

4. Reboot into Safe Mode

5. Uninstall the Oculus PC app using the Control Panel

6. Delete all Oculus folders from the following folder:

  • C:\Program Files

7. Remove any Oculus folders from the following locations:

  • C:\Users\YourUserProfile\AppData
  • C:\Users\YourUserProfile\AppData\Local
  • C:\Users\YourUserProfile\AppData\LocalLow
  • C:\Users\YourUserProfile\AppData\Roaming
  • C:\OculusSetup-DownloadCache
  • Note: The AppData folder is usually hidden. Use these steps to access AppData.
    • a. Press Windows key + R to launch the Run dialog window.
    • b. Type %AppData% in the Run box and click OK or press Enter
    • c. File Explorer will launch to the AppData\Roaming subfolder.
    • d. Click AppData in the File Explorer address bar to show all three subfolders in the AppData location.

8. Restart your computer in normal mode

9. Reconnect your computer to the internet

10. Install the Oculus PC app again using the setup tool from our website here.

11. Reconnect the Rift/Link cable and re-test the headset


If after these steps, an issue persists, it is likely not an issue with the Desktop app itself. Let us know if that worked out or not, and we'll see where to go from there!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey again, @pj39Jameson! Just checking back in to see if you were still having issues with using our software with your 4070 Notebook! Let us know if the above worked out or not, and we'd be happy to continue helping!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

@pj39Jameson any luck? I have the same issue. I can try the above steps but... seems a few of us with XPS's are having issues.


You might want to try putting it in GPU direct mode as opposed to hybrid mode graphics.  This may be in the Alienware control panel or bios directly (its been a while since I had one)  It may be detecting the Intel or AMD on die GPU (depending on model) by mistake.  There certainly is no technical reason that it cannot support all of the PC VR titles nicely fwiw.  Just need to get over the technical hump per se.  Good luck!

Hey thanks for the follow up. I finally had time to go through all of these steps and the issue still persists. 

Went through another support session with a technician today and my ticket 06606315 is getting transferred to higher level support.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?