cancel
Showing results for 
Search instead for 
Did you mean: 

Received Refurb Headset with old firmware from Oculus, can't set-up or update via iPhone app

Aim-Here
Level 2

Oculus Support sent me a refurbished replacement headset related to another matter. I received it today and when I went to set up the replacement using the (latest) iPhone app it required me to set up my Meta account etc. so far so good.  When I went to add the headset using the app. I get an error saying that my headset requires a software update before the setup can continue.  If I can't initially set up the headset how do I update its software/firmware?  The refurbished headset they sent had a pretty old version of the software on it (it still shows the Oculus "O" on boot). While I can log into my account just fine, my issue related to this update is having to update the headset to use the new app/account before it will run the initial setup routine (which is required to do any updates). It’s a Catch 22 and a which comes first, chicken or egg situation. 

5 REPLIES 5

grains671
Level 2

did you figure something out because i just got a refurb and i am unable to connect to the app because of this and am therefore unable to connect the controllers.

I was able to solve it myself as Oculus Support wasn’t being very responsive. It was a gamble and it was possible that I could’ve bricked my headset but it worked for me. Be advised there are no guarantees and it is a risk. I solved it by finding and downloading the image for the V43 headset firmware and then side loading it with my computer via the headsets usb recovery menu. I’ve linked a thread below that describes the exact process, provides a demonstration video, and links to the firmware and other files needed. Follow the link and then scroll down the thread to a post by Davidhalljr15 that describes this method. The next post is my reply saying it worked for me. No guarantees it will work for you, but after waiting and waiting for Oculus to help I decided to take the risk and it worked for me. 

Here is the link:
https://www.reddit.com/r/OculusQuest/comments/x13pw7/comment/in5biqb/

Hey there! That's not an experience we want our customers to have, and we'd love to help you.

 

Our engineers are aware of this problem, and they're working diligently on a solution for everyone.

 

Please reach out to our PM's so we can look further into your issue.

 

Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

I've opened like four support tickets so far and on the last one the guy just told me he has no idea himself why they arent shipping out new firmware or even just guiding someone through the sideloading process so that it wouldn't cause any issues with future warranty and such. I'll honestly just do the same as you and sideload it myself because I am very much done with this terrible user experience.

PrinceOfTime
Level 2

I am having a similar issue.  I had the initial headset that I purchased replaced (it was less than a year old) and the replacement sent does not synch with the controllers or my app.  I have a MAC and not a PC.  I have had numerous chats with customer support and was basically told to wait until a fix is done by engineers for MAC.  it's been a month since I have received the replacement headset and it still does not work!  I am very frustrated!