Showing results for 
Search instead for 
Did you mean: 

Red blinking light, stuck in an endless loop. (Solved)

Level 2


So uhhhh... I use the wrong charger... I used my phone charger instead of the one that cam with the Oculus Quest 2....


Hello everyone,


Intro (don't need to read this)

My Oculus Quest 2 has a red blinking light, meaning (what I read online) Its so empty that it can't do anything until its charged. When I use my Quest I plug it into a power bank, sometimes the headset decides it doesn't want to be charged so it depletes and turns off after an hour (maybe longer/shorter, truly no idea).

So this time again it didn't want to be charged and the battery depleted completely, even though I turned it off myself. I guess I didn't shut it off properly, because sometimes after turning it off, it turns itself on again (no I didn't press restart).



My quest gives a red blinking light, so I tried charging it. But when charging the red blinking light stops after a few seconds and goes solid white (meaning the screen is on). Its trying to boot up... Then the loading screen shuts off again and the light starts blinking red. This just goes on and on whilst its plugged into the charger. When I remove the charging cable nothing, but actually nothing happens. 


What I tried

- Charging it the entire day, (wasn't charged when I came home, also no blinking light)

- Pressing the power button whilst plugged in and unplugged. Tried holding, pressing repeatedly


None of these helped



1. What the hell do I do...





Level 2


Level 2

Did you solve this? Im facing the same issue

hey, from what I have learnt with the quest 2 is flashing red light means the headset is fully dead(0%) it may be the charger or you might need to manually update your vr (you can find how to do this on YOUTUBE) I had a similar issue and after the v34 update (I manually installed) I have not had it after.

Level 2

Goddamn ur such a life saver

Level 2

I have almost the same problem but it doesn't have the white indicator and I'm using the charger for my OCULUS quest 2

Never mind figured it out just had to let it sit for a minute the plug it in the opposite way.

Level 2

I have the exact same problem and nothing has worked I don't know what to do 

Hi, sorry for bothering you, may I ask have you solved this problem? I have the same problem now and changing the charger isn't a workable way for my quest 2...

Hey there. We know what it's like to want to play your favorite game, but you're unable to since you're headset isn't properly charging.  Let's see what we can do to help.


We recommend you try to charge the device in a different outlet for two hours and try a different charging cord.


If you're still having issues, we suggest reaching out to Support HERE to further assist you with your headset as it definitely has power issues.