cancel
Showing results for 
Search instead for 
Did you mean: 

Red blinking light, stuck in an endless loop. (Solved)

The_Njitram
Level 2

(Solved)

So uhhhh... I use the wrong charger... I used my phone charger instead of the one that cam with the Oculus Quest 2....

 

Hello everyone,

 

Intro (don't need to read this)

My Oculus Quest 2 has a red blinking light, meaning (what I read online) Its so empty that it can't do anything until its charged. When I use my Quest I plug it into a power bank, sometimes the headset decides it doesn't want to be charged so it depletes and turns off after an hour (maybe longer/shorter, truly no idea).

So this time again it didn't want to be charged and the battery depleted completely, even though I turned it off myself. I guess I didn't shut it off properly, because sometimes after turning it off, it turns itself on again (no I didn't press restart).

 

Problem

My quest gives a red blinking light, so I tried charging it. But when charging the red blinking light stops after a few seconds and goes solid white (meaning the screen is on). Its trying to boot up... Then the loading screen shuts off again and the light starts blinking red. This just goes on and on whilst its plugged into the charger. When I remove the charging cable nothing, but actually nothing happens. 

 

What I tried

- Charging it the entire day, (wasn't charged when I came home, also no blinking light)

- Pressing the power button whilst plugged in and unplugged. Tried holding, pressing repeatedly

 

None of these helped

 

Questions

1. What the hell do I do...

 

Greetings,

Martijn

16 REPLIES 16

Hi, thanks for your suggestion, I have tried to charge the device with 3 different outlets but they all did not work.

I have emailed the support team, hope to get in touch with you soon.

Hey again tilikum1912. We just wanted to let you know that we responded to your support email from us. We look forward to a reply from you.

luckyduck45
Level 3

SAME THING IS HAPPENING TO ME RN AND ITS MAKING ME SO MAD

Same and its making me so mad

 

Same man 😕

MetaQuestSupport
Community Manager
Community Manager

Hey there! That's not what we want to hear from our valued customers. We'd love to see what we can do to help you with your device not charging.

 

Can you please do the following?

  • Charge the device at a different outlet on the charger for two hours.
  • Try a different charger to see if it works after two hours.

 

If none of the troubleshooting steps have worked, the next step would be to reach out to support to see what options are available to you HERE.

Nobody8686
Level 2

I got my quest 2 out of the same red flashing, restartig loop by plugging it in an very low powered charger, 5v 800mA. Maybe the quest just recognized, that it could not start with that low charging power. After 15 minutes I could change the charger and the quest charged normally with my regular charger again.