cancel
Showing results for 
Search instead for 
Did you mean: 

Resilient "Sensors can't track headset" error (update: they came around)

Knutsi
Protege
Update June 26th: I replied yesterday that I believed their last request was illegal in the EU/EAA (*) and they finally came around and told me that after a review of the case they would not send me a new headset. I got a tracking number today. UPS can still not see the package, but I choose to believe this is the end of this story. I will not post further updates unless this derails yet again. 

* You can read up on your rights here. I consulted a few people around me as well, who agreed this case was very bad. I have sent a request to a national consumer rights authority, but will cancel this if everything works out now.

Update June 25th
:  Oculus informed me today that "it looks like we were unable to replace just the headset at this time, and must replace the full kit instead". They now want all the items back despite explicitly saying otherwise initially. I will have to pay for the shipment myself, and the address is provided. The rep. is also saying there might be promotion credits as a thank you for my patients. Before I comply with this I need to check with my EU/EAA consumer rights organisations if they are allowed to do this. I believe they need to cover the cost of the returns of a broken product? In any event, this is outrageous, and all the burden in placed on the consumer. I'm five weeks in, and this process is preventing me from buying a new headset + the partial return made it hard to request a refund and close the whole process. This is without doubt the worst online retail experience I've ever had, and I want everyone to know they need to be very cautious ordering directly from this company. 

Update June 24th
: Oculus has still not sent my replacement. It's been a full month now. In two days it will be five weeks since the broken headset arrived, and I am still not able to use the headset I pre-ordered for release from Oculus.com. All this time they have not been out of stock.

Update June 19th
: The replacement for the pre-ordered Rift S headset that arrived broken (worked for 5 minutes) will now take more than a month to arrive to me. The package arrived in their facility before the weekend. Despite assurance the replacement would be sent immediately when they see the package "moving in the system", the replacement has not been sent from them yet. No matter how much problems they've had, 30+ days for them to replace something broken is not nice. (I dont live in a place where shipping takes long either - their facility is reasonably close).

Update June 8th
: shipping labels arrived two days ago, and I sent the package yesterday. 

Update June 4th
: Oculus Support (@OculusSupport) has still not sent the labels for the return of the broke headset, and their support notified me this night that "it looks like we have encountered a number of issues on the backend which have created some delays with processing replacements". I appreciate that they reached out to me to let me know this (the message was personal, not boilerplate), but the wait keeps adding up. They are basically saying getting a replacement will take a while. Meanwhile, new headets ordered from Oculus.com ship within a day, I've asked if I can just get a refund, and I could just buy a new headset from their site or retail.

Update May 31st 2019:
So they did yesterday decide to replace the headset, as expected. The time projection is my new headset will arrive within 10 days of returning the old one. The return label has not yet arrived (it will be from a local partner, I suspect), but I'll keep updating this post with what happens next. I'm happy there is some movement at least. 

Update May 30th 2019
:  Oculus support has still not committed to taking the headset back or replacing the cable, but said they are looking deeper into the issue at least.. They have once requested I run the log collection again, and sent a general notice they are overloaded. Since the OP was written I have tried the new firmware from the public test channel as well, and asked support if there was any way to hard reset the headset or its firmware/components (there was not). Let me also add that the two machines I tested the headset on have different architectures. One is a MSI VR-ready laptop, and the other a self built tower with a very recent ASUS motherboard targeted at gaming,.

Original post May 24th 2019: Just wanted to share the lack of progress on my apparently broken Rift S after discussing it with Oculus support today. So one important thing is that the headset actually worked for a few minutes when I first set it up, lost hand tracking and never recovered. On the next setup, it got stuck in "sensor check".

After trying everything from reformatting the disk and reinstalling Windows, using a different machine, different USBs 3/2, a powered hub, re-installing software, checking I was not running Windows N, ensuring camera privacy settings were right, restarting the service, and much more I got through to Oculus Support (on Chat) which today suggested:
  1. Re-installing the software in safe mode and deleting some folders in AppData etc.
  2. Trying to at least three times un- and re-plug the cable at the headset end, giving it one minute before reinserting.
The headset still does not get past the headset sensor check, and fails with the error in the screenshot. "Skip setup" leads to the headset having sound, but no tracking, and the video being three blinking dots, as seen in the video: https://www.youtube.com/watch?v=tphMVNJFN2E&feature=youtu.be 

The rep said the logs did not look like there was faulty hardware, but what else can it be at this point? The USB plug on the PC side of the cable gets very very warm. Maybe it's the cable, who knows. I'm awaiting a reply from them now.

fke37hl40orh.png8mvjsrd7p8qo.pngevlfk2sjcpx5.png560qcyh3uzbi.png
90 REPLIES 90

Javelin396
Adventurer
i had this problem too, i fixed it for me by going to the devices tab on oculus desktop app, selecting rift s and touch, scroll down to forget device, then i disconnected the cables and went through the device setup again.

qtjequirijn
Explorer
No progress for me yet

Knutsi
Protege
Aidens12 said:
i had this problem too, i fixed it for me by going to the devices tab on oculus desktop app, selecting rift s and touch, scroll down to forget device, then i disconnected the cables and went through the device setup again.
Thanks Aidens12, but after doing this many times, reinstalling windows and trying the headset on two different PCs that were both either formatted/reinstalled or reset using the option to reset windows, this does not apply in my case.

dualdier said:
I tried the generic driver on my intateck USB hub and my Rift can now detect the sensors!!!
Thanks for the tip, but the USB driver used is already the generic Microsoft driver. I have also installed the Asus motherboard drivers, and flash the BIOS to the latest version.

No progress for me yet

Me neither. And Support is still quiet. If there is no reply by Tuesday I will try the chat again. Since the headset doesnt work or freshly installed PCs of two different producers, I cant see how anything short of a firmware update to fix something broken, or a replacement headset would solve this. 


UnfoldingBoot
Honored Guest
I'm not entirely sure if this will help you, I was using a 3.0 port in the front of my tower and it would take multiple disconnects and reconnects to get passed the sensor check at all, then when it did and I would try to play something the tracking would drop after a minute or two and then it was back to multiple attempts to get passed sensor check. I suspect it had something to do with my current USB 3.0 ports not supplying enough power to the Rift S because as soon as I tried a PCI card everything has been working beautifully. This is the one I got
https://www.amazon.com/FebSmart-Self-Powered-Technology-No-Additional-FS-U4-Pro/dp/B072LS4JH7/ref=mp...

Knutsi
Protege


[...] I suspect it had something to do with my current USB 3.0 ports not supplying enough power to the Rift S because as soon as I tried a PCI card everything has been working beautifully  [...]


It might work for some. But there are also reports over at reddit of it not working. I did try the Rift S on a second PC, so to be honest, the chance of neither of these machines not being compatible with the device is probably very very low. It's very tempting to buy such a card tomorrow and try, but like someone on this forum stated before "there is no way [the Rift S] can be that finicky".

I appreciate the advice however, and I'm happy it worked for you (:  

(I have also tried to run the Rift S of a powered hub, and I was using 4x external sensors for the original Rift on the same PC before, so I'd be surprised if this was the issue).

Anonymous
Not applicable
As @UnfoldingBoot said, this is what finally worked for me.

I spent 12 hours over the course of 2 days trying to get it to worked. tried everything. 

Eventually went out and bought a USB 3.0 Hub with its own power supply. Still nothing.

Returned it and got the PCI usb card, and boom it worked! although still buggy....

After i installed the PCI card, during the DisplayPort and USB 3.0 check, i was failing the USB check (which was a first).
So i plugged it into the other usbs (that i was using before) and it passed, and as usual it failed the next stage - failed to connect to sensors.

During that stage, i plugged the usb back into the PCI card and thats when it all worked!

Knutsi
Protege

TheDilz said:

As @UnfoldingBoot said, this is what finally worked for me. [...]  and got the PCI usb card, and boom it worked! although still buggy.... [...]


Congrats (: Enjoiy VR ;). Did it ever work for you before the PCI card, and did you try the headset on other PCs?

Anonymous
Not applicable

knutsi said:

Congrats (: Enjoiy VR ;). Did it ever work for you before the PCI card, and did you try the headset on other PCs?


No i was never able to get it to work before, and didnt try it on any other pc's

Knutsi
Protege
yeah.. I'll contact support again tomorrow. The more I read about other people's problems here, the more certain I get my unit is quite simply broken - and broke 5 minutes into the first game I played. Alternatively the cable is broken, but since there is not replacement part for the cable on Oculus.com, I can't know.

Morgrum
Expert Trustee
This is going to sound weird but try plugging your headsets usb into a powered usb hub.
It could be as simple as my issue where the headset wasnt getting enough juice and the powered hub fixed everything for me.

This goes double for laptop users.
WAAAGH!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?