Showing results for 
Search instead for 
Did you mean: 

Resolved: Error saying "We're having problems loading this" when enabling developer mode

Honored Guest

Hi everyone!


Headset: Oculus Quest 2


Problem: When I toggle the developer mode switch in the Oculus iOS app, a red banner populates on the bottom of the screen stating "We're having problems loading this. Please try again."


What I have tried: I created an oculus account, created an organization within, factory reset my quest 2, paired with my iPhone, and attempt to put into developer mode and I get the same problem. I have deleted and reinstalled the app, I have deleted and created new organizations in the developer account, and I have factory reset the headset countless times.


Is anyone else experiencing this? It worked last week!!



661 REPLIES 661

It doesn't exist. Hundreds of people have been complaining about this for the past week and this **bleep** bot keeps saying the same thing about that same link, and yet NOTHING is written there about this whatsoever. It's completely ridiculous and shameful.


Be great to get any response from meta. Nothing but crickets

I did :hundred_points:

Same here, I can't get some work done 😕

Tried: Restarting headset & mobile device, Reinstalling App, Created multiple organizations, factory reset

i have 2 headsets for development and neither of them are working for developer mode reset everything reverified my accounts and still can not enable developer mode on either of my headsets

I did 😆

No from what i understand they removed the ability to downgrade firmware in a earlier release.

as there updates tend to break headsets i think the ability to reflash an earlier firmware being removed was a ridiculous thing to do

No firmware got posted after v20 that i could find which i presume was when they removed the ability to downgrade your headset


Same problem since yesterday.
Added credit card information, reset the quest etc.
Nothing works.
Developing something for the Pico 4 is easier. Why are there always problems like this with Meta?

is someone found a solution???????

same problem .. is there a solution?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?