cancel
Showing results for 
Search instead for 
Did you mean: 

Resolved - Meta Quest App - Blank Screen on iOS 16.2+

clarkerz
Protege
After installing the Meta Quest app on my iPhone 13 Pro Max and pairing all was well and worked OK. After going back to the app on my iPhone the screen flashes briefly and then goes blank (light grey). The exact same happens on my iPad as well. If I uninstall both and and reinstall then it all works fine again, until I close the app and then try and re use later.
 
iPhone 13 Pro Max - Model MLLA3B/A - iOS Version - 16.1.2
 
iPad 2018 6th Gen - Model MR722B/A - iOS Version - 15.6.1
 
The video is not great but shows the issue. I cannot find anyone else having a similar issue anywhere.

A video of the issue 

94 REPLIES 94

What seems to work, (I haven’t tested after a casting session yet):

1) uninstall the meta app, delete data? Answer Yes.

2) reinstall meta app

3) sign in, use the app

4) !!!! SIGN OUT !!!!

5) Dump the app

6) Starting the app subsequently will not result in gray/black pop up window (as long as I sign out each time)

Additionally, if you are casting - before you turn off the Quest 2 headset!!!:

1) Stop the casting

2) Sign out of the app

3) [Dump the app]

4) Turn off the Quest 2 head set

 

Failure to stop the casting (which prevents seeing the "Sign Out" button), and signing out will cause the app to be unresponsive (gray/black blank popup) the next time the app is started, which then is only fixable by deleting the app, the app data, and reinstalling.

 

 

The latest Meta Support response to me:
 
[quote]

Upon checking, we are receiving several reports about this issue and we've already notified our higher department. Our engineering team are now working on a fix to get it back up and running again as soon as possible.
 
I apologize for the inconvenience that this is causing you. Rest assured that we will get back to you once update is available.
 
For now, I have immediately took note of your ticket and forwarded it to our designated team to work on your issue as soon as possible.
 
Should you have queries or need assistance, please do not hesitate to reach back to us. We care about serving our customers and we have always believed that we leave no stone unturned to make it possible.
 
Kind Regards,

name redacted
Meta Store Support

[/quote]

still not work😡

Have you tried?

1. Uninstall app

2. Install app

3. Open app, Sign in

4. Sign out

5. Close app

then repeat steps 3, 4, 5 

Does that EXACT sequence work?

 

Hi, I tried and your suggestion does not work.

What method is not working for you?

s.hester
Honored Guest

Thank you the logout method also appears to be working for me. (iPad Air and iPhone XR)
For me the open with oculus button and web VR games is not working.

 

I think I have also found a work around as well, it's not been fully tested but has worked for the last couple of hours.

After the first initial load, once the black/grey screen starts to appear if I close the app completely and then use the Open button from the app store, then it loads the app. Sometimes I've found it takes a few attempts and I need to close the app each time (not just minimise it) but after a couple of tries it loads.

I'll try on the iPad tomorrow after casting but this is working for me on the XR hope it helps someone else out as well

kevin.007.2022
Honored Guest

I have the same issue with my iPhone 13/iOS 16.1.2.

The recommended solutions did not work. Constantly uninstalling and reinstalling is cumbersome and frustrating.

Storm07567
Honored Guest

META QUEST SUPPORT... I have seen and have experienced the issue with the Meta Quest app on iOS crashing into a grey screen. I have seen the band aid fixes that people are suggesting

  1. Open Meta Quest app on iOS... Grey Screen
  2. Open setting on iPhone and go into airplane mode
  3. Return to app and swipe to close
  4. Turn off Airplane mode
  5. Open Meta Quest app and it resolves the grey screen...

    OR 

Uninstall and reinstall the app

These are ALL temp fixes to a problem that you have not addressed yet. WHAT is the root cause of this consistently happening on iOS devices and when will Meta fix it? I have the latest iPhone (14 Pro Max on the latest firmware) and it still happens and I have seen people as far back as the iPhone XS having the same issue... so it's not an iPhone thing, it's an app problem that needs to be addressed by Meta. This is unacceptable to have to jump through hoops to get an app to work properly with a device that is $500.

Please someone at Meta chime in here at provide an update as to when we can expect this to be fixed?

Alsomio
Honored Guest

Getting the same issue still! on a iPhone and have tried the “solution”. After seeing this post is over 3 weeks old you would think they would have updated the app for a show stopping bug…. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?