Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest 3 Elite Strap with Battery only connects for a few seconds

Honored Guest

Is anyone working on the Quest 3 elite battery issue?  It charges but won’t connect to the headset for more than a few seconds, meaning you cannot charge through the back port.


Accepted Solutions

Meta Quest Support
Meta Quest Support

We’ve seen some people having trouble with their Meta Quest 3 Elite Strap with Battery not being recognized by the headset or not charging. We’re happy to help look into this with anyone having trouble, and we recommend contacting our support team here so we can take a closer look.

Sometimes it's okay to be a little Bing Chilling

View solution in original post

837 REPLIES 837

So far my Quest 3 ownership has been awful. Firstly my Quest arrived with a dead bright green pixel, then along with my Quest 3 I purchased the Elite Battery Strap as well as the Quest 3 charging dock which is advertised as being able to charge both Quest 3 and Elite Strap.

However, when I turn on the headset I only see the Quest battery displayed and not the Elite Strap, then if I unplug the USB C lead from the Elite Strap that goes into the Quest and then plug it back in it gives you the pop up saying extended battery installed for around five seconds before disconnecting and then the extendable battery no longer shows.

This seems to be a widespread issue with many on Reddit reporting the same issue. Some exchanging their Elite Straps and finding the issue resolves itself and others where it doesn’t. No word from Meta as to whether this is a hardware or software issue, but I have to say this has been a really poor release by Meta. I had none of these issues with my Quest 2 and right now I’m questioning why I spent nearly £1000 on this rubbish! Meta’s support channels are inundated with complaints apparently when I chatted to them the other day and they said to expect extended response times as a result.

Anyone else had this issue though?? @MetaQuestSupport 

I have exactly the same problem!

Same here and for at least 20 other users that have shared on this Reddit post:

We have a problem here Meta. Would you care to at least chime in that you're aware, we're not alone and this is hopefully being remediated with an update we will get to download soon? Very frustrating. It's bad enough my headset drains a % per minute with nothing more than UI navigation. 

Same here. It worked fine for a couple days now I’m dealing with this after spending all this money on this thing. 

Same here. Plug the elite strap into the headset - shows up as connected for about a second or two then disappears again. Elite strap battery is at 100%. It worked as designed the first time I plugged the two together but this broken behaviour started as soon as I drained and recharged the headset.

Seems weird and makes me think this is software related, but the fact Meta are being so tight lipped and not even acknowledging or responding to support tickets leaves us to wonder. 

Meta Quest Support
Meta Quest Support

[edit] - NOT AN ACTUAL SOLUTION - THIS ISSUE IS NOT RESOLVED YET - WE'RE STILL WORKING ON IT - NOT A SOLUTION BUT UPDATES ON ISSUE - marking this comment as the solution since I want to make sure everyone can see the updates right away and not be missed. (sorry again for misleading solution but it is necessary *so that everyone can see the updates*)

[Edit 10/17] - The team has provided me with this - Elite Strap with Battery shows up in VR briefly when connected to the headset. After that you must hover over the battery indicator to see the battery levels of headset and strap separately. Display shows the average. Please let me know if you're able to view the percentage correctly!

[Edit 10/16] - Looks like the team has provided me with some troubleshooting and have let me know that they are currently working on this issue. Let me know if anything below helps out or not and I'll pass it along:

  1. Make sure the Quest 3 headset has the latest software version.
  2. Unplug and replug Elite Strap into headset. Make sure the headset is powered ON.
  3. Press the battery once on the Elite Strap and check LED color.
    • Green: Fully Charged
    • Orange: Charging
    • Blinking Orange: Low Charge
    • Blinking Alternating Colors: Error. Try resetting by pressing the button for > 12 seconds while not attached
    • No LED: charge the Elite Strap for at least an hour. This means a very low battery level.
  4. If Elite Strap is not charging the headset
    • Try unplugging and replugging from headset
    • Try unplugging and replugging from AC adapter
    • If nothing works, try holding the button down for >12 seconds
  5. If Elite Strap is not getting charged by the headset through the dock, make sure to wait at least 2 hours until the headset is fully charged. Charging prioritizes the headset.
  6. To reset the Elite Strap with Battery, hold the button down near the back of the strap by holding the buttons down for > 12 seconds.


Hey hey, guys! I was scrolling through reddit and I noticed a couple posts about this issue so I decided to gather them up and ask someone about it. As soon as I get some updates, I'll edit this post. 


Sometimes it's okay to be a little Bing Chilling

Same issue with the strap battery. In headset, only main battery shows percentage with strap battery plugged in. Unplug the strap battery, percentage doesn’t change. Plug it back in, percentage updates, message appears that battery life has been extended, and then disappears, and then only shows headset charge percentage.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?