cancel
Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest 3 Elite Strap with Battery only connects for a few seconds

jdd1.2023
Honored Guest

Is anyone working on the Quest 3 elite battery issue?  It charges but won’t connect to the headset for more than a few seconds, meaning you cannot charge through the back port.

837 REPLIES 837

Regarding the display of battery percentage, my experience is the same as others here.

When I put the headset on with the elite strap battery already attached, all I see when I hover over the battery icon is the headset battery percentage.

If I unplug the USB-C cable from the elite strap battery and then plug it back in again, then the headset makes a chime, then I receive a notification that an extended battery is installed, and a new icon appears beside the battery percentage, during which time if I hover over the battery icon, it will say ' headset x%, extended battery x%' with the overall percentage number changing to account for the extended battery. Within a few seconds, the new icon disappears, showing only the battery icon again, and the battery percentage changes back to what it was before, and when you hover over the battery icon it will again only say 'headset x%'.

This is repeatable whenever the USB-C cable is unplugged and then plugged back in.

When I hold the button on the headstrap battery in for 12 seconds, then this whole process occurs twice in rapid succession.

The end result is always the same. The battery icon shows 'headset %' only and the headset will drain all the way to 0 without ever using the charge from the attached elite strap battery, all while the elite strap battery LED indicates green when plugged into AC or when the battery button is pressed.

I hope this helps.

We can also provide videos via in-headset recording if that helps.

That is exactly what happens on mine as well.


@TheAntiSocializer wrote:

[edit] - NOT AN ACTUAL SOLUTION - THIS ISSUE IS NOT RESOLVED YET - WE'RE STILL WORKING ON IT - NOT A SOLUTION BUT UPDATES ON ISSUE - marking this comment as the solution since I want to make sure everyone can see the updates right away and not be missed. (sorry again for misleading solution but it is necessary *so that everyone can see the updates*)

[Edit 10/17] - The team has provided me with this - Elite Strap with Battery shows up in VR briefly when connected to the headset. After that you must hover over the battery indicator to see the battery levels of headset and strap separately. Display shows the average. Please let me know if you're able to view the percentage correctly!


After starting the Quest 3, the Battery-Elite Strap is NOT recognized at first! Only when you pull it out of the USB-C port and plug it in again, it is permanently recognized! See the following video:

https://youtube.com/shorts/GKrMolwex5s

As for connecting to a computer, the headset is recognized briefly and then disappears again. At some point, you have that mostly a stable connection. It's like a loose connection. See the following video (turn up the sound to hear when Windows detects the Quest and when it loses the connection again):

https://youtu.be/apX-bVEKF_w

P.S.: I tried several cables and USB-Ports on my Computer. The problem still presists!

Rucan
Explorer

I have this issue, i whant a refund but the strap have no refound button on my order !!! What the hell 🥹

Screenshot_20231017_195705_Edge.jpg

I agree, it sounds like the developers are clutching at straws here! There doesn’t sound like there is any idea as to what is causing this issue. All we can hope is that they pull their finger out and start working on this instead of offering workarounds that do not work. I’m also appalled at the customer service from Meta. 4th time I’ve raised a case with regards to my faulty headset and Elite Strap issue and I finally get one message this morning on WhatsApp with a representative saying I will be assisting you, here is a case reference. Then I replied soon after and heard nothing back since! It’s ludicrous! Did I reach my one message a day limit?! 🤷‍:male_sign:🙈😂

This is EXACTLY what I was dealing with as well in terms of the connecting/disconnecting from the PC which seems completely unrelated to the Elite/Battery strap although they both of the USBC port in common in terms of problems.

 

Meta, can we get some sort of update on what's going on here and when/how you will fix?

They simply do not know and that is the truth right now. They are asking us to fiddle around with workarounds that we all have tried already, and yet nothing works. 

Looks like we are just going to have put our headsets down and wait for Meta to finally tell us what is going on. 

 

That will only temporary fix the problem. If your video was about 30 seconds longer you would notice that the headset battery level is still shown while the elite battery strap percentage disappears again. 

jdd1.2023
Honored Guest

Hi, I called Mets customer service and they said based on the serial number that I was eligible for a replacement.  They were going to send one but it was faster to return for a new one locally.  The new strap and battery work as expected.  They also said that it is not a firmware issue.

I assume you are in the States? There is no number to contact here in the UK, only email and WhatsApp. They told me the same, but my local retailer has sold out of 512gb and don’t know when they will back in stock, so I’m having to go through Meta. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?