Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest 3 Elite Strap with Battery only connects for a few seconds

Honored Guest

Is anyone working on the Quest 3 elite battery issue?  It charges but won’t connect to the headset for more than a few seconds, meaning you cannot charge through the back port.

711 REPLIES 711

As Meta wont go into any specifics besides PR, I've taken some time and looked at my own occurence and the possible failure modes I've gathered from both Reddit as well as some German-language forums:

a.) Left strap plugged overnight, Quest 3 discharged the strap battery slowly (typically between 15-20% in 12h) until there was no power left and we move to the second scenario:

b.) You used the Headset until strap-battery was empty and internal battery took over; regardless leakage current further reduced the power of the strap battery below safe-low-voltage and damaged the battery.

In both cases we're looking at a deep discharged Li-Ion battery, which basically means the battery is dead and no amount of software will fix it. Of course safety measures can be taken in place for new / replaced straps with updates, but if this case there is no hope for already damaged units.

For the people with working straps: Unplug it, just to be safe.
For the customer support: I'd be happy to be proven wrong, please let us know what is really going on.

Unfortunately, mine worked perfectly for over a month and then suddenly started having this problem. I thought I was safe, but there's obviously a design flaw.

Hoping for a software fix, but I have my doubts. I'm worried that the battery strap disconnecting quickly means that it might not be possible for the headset to push a firmware update to it.

And I'm not sure about the deep discharge theory. Mine says it's at 100% for the couple of seconds before it disconnects. I have the charging dock and have always left it on there when I'm not using it, so I don't think the battery ever had a chance to run down.

Can confirm, my strap neither accepts charge nor does it provide charge to the headset but it still has some charge left as indicated by the LED on the strap.

I run mine down to zero every other day or so. I think it disconnected once on v57, and just unplug/replug fixed it. But since v59 I havent had that happen at all. Have been using since 10/18, but 100% charging on dock 


As I said, I'm happy if the deep-discharge take is debunked.

In case there is a software-related issue to charging - does anyone had luck with the v60 PTC?


Hi, I can also confirm that my strap battery was not empty when I first experienced this disconnection issue. It also appears briefly as 100% (now 98% after my numerous reset attempts 😉 in the first seconds after it is reconnected. 
I observed that sometimes after a reset attempt (I say attempt as I have no clue of any battery feedback that any reset - 12 sec button push - worked) the strap battery connexion lasts a few more seconds. Like until 10 - 15 seconds. That was an emotional roller coaster as I thought the issue was fixed... but NO! 
So not sure this is linked with the battery being fully discharged. 
Another hypothesis to investigate: what about the use of a 5m USB cable connected on the strap battery from time to time? 

I just chatted with support, he was like, "best option right now is to return it" and mentioned that tech support has no info if a software fix will or even is possible. I pressed him for 30 mins on the question.


I personally don't see much value in returning it. This problem has to be addressed eventually, either with a software update, or with a hardware revision (at which point we had all better be compensated with a replacement). I don't want a replacement until it's fixed, and I don't want to be without it, even if the battery isn't working (I found the original strap to be unusable). The other option is to get your money back and switch to a third-party solution, it's just not the direction I'm looking to go.

I'm waiting for someone else to be brave enough to either put theirs in the freezer or take it apart and test the batteries.

I have seen people reporting problems with third party solutions as well, though


The disconnection issue to me indicates more of an issue with the USB chipset, perhaps on the Quest 3 headset itself.

It's not a headset issue, or not only. I can charge my phone from the Elite Strap with Battery, but it too disconnects after a few seconds.


And I am just returning it, no refund. But I also have a dead pixel on the headset... so I think I'm just going to leave the Quest entirely for now. Quality is just too low.