Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest 3 Elite Strap with Battery only connects for a few seconds

Honored Guest

Is anyone working on the Quest 3 elite battery issue?  It charges but won’t connect to the headset for more than a few seconds, meaning you cannot charge through the back port.

837 REPLIES 837

Good to know it's a new batch. They're back on stock in the UK store and I have on just shipped to me. I hope there's good news on your side @byronhinson.


Just received replacement (UK), all brand new, seems to work currently has taken since 21/10/23 initial fault to get a replacement, had to use both the whatapp and mail, (took 7 days to get a response via whatsapp) good luck all... fingers crossed it stays operational.



Yeah my replacement came and works fine so far. Manufacturing date of this month too so clearly the new batch 

Mine has just arrived too, seems to recognise when plugged in, let’s give it a few days of testing and see how it goes, tbf my original worked for a few days before it went Pete tong. Although I have some faith now, Meta can’t get it so wrong a second time round… could they?

Honored Guest

Mine arrived today as well, way earlier than expected. Everything seems fine (not a replacement in my case). Battery report is interesting because it reports the total for both headset and strap, but if you hover then it'll give 100% for the headset and the rest for the strap.


The status has been that way since mostly the beginning if not the very beginning.

Has there been any discussion of what the actual trigger for a problem is?

I still have the strap I ordered a week after launch and it works flawlessly for the most part even when I run it down to zero, I play every day or every other day

Honored Guest

Side question: this is something only that I only noticed slightly without the battery strap but now it's shouting to me with it. When it's powered down and I press the power button just for a moment to check the battery's status, the text is heavily tilted to the right. The loading Meta logo is as well but it's much less noticeable.

I thought this was for particular unit but I have two bought over the last month, one from Meta and one from Amazon and both have the same problem (it seems to be an incorrectly calibrated IMU).

Is this not happening to anyone else in this thread?

I'll reply to myself to the tilting problem: after some external help today I learned that due to the shape of my face it's only comfortable for me to wear the headset fairly tilted. This is noticeable within the headset only in views where there's a head lock, not a horizon lock.


Have not looked since I returned mine some time ago, is the issue actually resolved? I tried to find one on BestBuy and Amazon and it seems it's been pulled, no one is selling it?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?